Closed Bug 1490391 Opened 2 years ago Closed 2 years ago

firefox for android duplicates letters with some keyboards

Categories

(Firefox for Android :: Keyboards and IME, defect, P1)

Firefox 62
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
relnote-firefox --- 63+
firefox62 --- wontfix
firefox63 + verified
firefox64 + verified
firefox65 + verified

People

(Reporter: chrd5273, Assigned: jchen)

References

Details

(Keywords: regression, Whiteboard: [priority:medium][geckoview:klar:p1])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:62.0) Gecko/62.0 Firefox/62.0
Build ID: 20180827144136

Steps to reproduce:

Go to google, try to type '파이어폭스'. Every sites rendered by firefox suffers this bug. Address bar is not affected.


Actual results:

파이이어어포폭스 appears.


Expected results:

파이어폭스 should appear.
Hi, thanks for your report. 
I tried to reproduce your issue on the latest version of Nightly 64.0a1 (2018-09-11) and Release 62.0.1 with following devices: Samsung Galaxy S8 (Android 8.0.0) and Nexus 6 (Android 7.1.1) but I can't. Do you have some additional steps or specific option? And could you please give us some more information regarding your device? (make and android version)
Flags: needinfo?(chrd5273)
(In reply to Stefan Deiac from comment #1)
> Hi, thanks for your report. 
> I tried to reproduce your issue on the latest version of Nightly 64.0a1
> (2018-09-11) and Release 62.0.1 with following devices: Samsung Galaxy S8
> (Android 8.0.0) and Nexus 6 (Android 7.1.1) but I can't. Do you have some
> additional steps or specific option? And could you please give us some more
> information regarding your device? (make and android version)

Hi, Deiac. My device is galaxy note 5(SM-N920K) and android version is 7.0 (kernel version 3.10.61-14077807). Date of latest security patch is 2018/8/1.
No additional step is required to reproduce the bug; trying to type in google search bar after restarting firefox reproduces the problem.
Reinstalling firefox still gives same bug so I doubt that it is a matter of configuration.
Flags: needinfo?(chrd5273)
Through (In reply to Stefan Deiac from comment #1)
> Hi, thanks for your report. 
> I tried to reproduce your issue on the latest version of Nightly 64.0a1
> (2018-09-11) and Release 62.0.1 with following devices: Samsung Galaxy S8
> (Android 8.0.0) and Nexus 6 (Android 7.1.1) but I can't. Do you have some
> additional steps or specific option? And could you please give us some more
> information regarding your device? (make and android version)

After some more testing, I found that this only happens on specific keyboard setting.

I don't know whether there is name for this behavior, but if you turn on 'word suggestion' option on your keyboard, you see underline on the word you currently typing. The bug I described only happens when that underline is not appearing. i.e. Turning on 'word suggestion' on default samsung keyboard suppresses this bug, and turning off 'word suggestion' brings back the bug. Also, some keyboard displays that underline even after turning off the 'word suggestion', suppressing the bug.

I hope this information could help.
Hi, thanks for your update.
I still can't reproduce your issue following the additional information from comment 3.
Device: Samsung Galaxy S8 (Android 8) and Samsung Galaxy tab S3 (Android 8). Can you send us a video with the issue?
Flags: needinfo?(chrd5273)
This likely requires the Samsung Keyboard that is shipping on that phone. I expect that as a workaround using the Google Korean keyboard or other 3rd party keyboard that is more up to date than stock keyboard.
(In reply to Stefan Deiac from comment #4)
> Hi, thanks for your update.
> I still can't reproduce your issue following the additional information from
> comment 3.
> Device: Samsung Galaxy S8 (Android 8) and Samsung Galaxy tab S3 (Android 8).
> Can you send us a video with the issue?

Hi Deiac, sorry for being late.
I'm not sure how to upload video on bugzilla, so I'll just link my youtube video link.
https://youtu.be/L3tteQkt3Fo
Flags: needinfo?(chrd5273)
Replication on other keyboard(도돌 키보드): https://youtu.be/nns9fTtD7zo
Typed more slowly, and also recorded the effect of word suggestion(단어 추천) option.
(In reply to Kevin Brosnan [:kbrosnan] from comment #5)
> This likely requires the Samsung Keyboard that is shipping on that phone. I
> expect that as a workaround using the Google Korean keyboard or other 3rd
> party keyboard that is more up to date than stock keyboard.

Gboard is one of the keyboards that always draw underline on words. So it is actually a workaround, but bug is still there with other keyboards...
Hi, thanks for your updates.
Tested with the new information from you and I can confirm the issue with qwerty keyboard (2-bulsik and Single vowel)
Device: Samsung Galaxy S8 (Android 8.0) 
Version tested: Nightly 64.0a1 (2018-09-18)
Can confirm the issue in the latest version of Firefox Release (62.0.1) and beta 63.0b7 on Samsung Galaxy S8 (Android 8.0)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → ARM
OS: LineageOS 14.1 (Android 7.1.2)
Keyboard: Android Keyboard (AOSP)
Firefox: 62.0.2

Typing "Firefox" -> "FFirefox"
Typing "abc" -> "aabc"
Typing "Hello" -> "HHello"

Firefox 61.0.2 works correctly. This is enough to justify a new 62.0.3 release, IMHO.
I'm waiting for the fix for a month. Why Mozilla isn't fixing this?
NI to sdaswani for priority
Flags: needinfo?(sdaswani)
Flags: needinfo?(sdaswani)
Whiteboard: [priority:medium]
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
QA Contact: nchen
Regarding the issue of Firefox in Korean, it seems that we expose the input field in the google page a little different than how Chrome exposes it or how it is used in the address bar. Hence the keyboard behaves differently and enters that different than expected text.
Assignee: petru.lingurar → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 1496734
Summary: firefox for android incorrently handles korean input → firefox for android duplicates letters with some keyboards
Duplicate of this bug: 1495985
Although I'm not sure whether this is exactly same as bug 149585, I see similar issue when I type data URI into the awesome bar. Autocomplete (appearing selected text) causes duplicates the composition string.
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
This seems to be a regression introduced in the July 18th Nightly and in 62.0b15.
Jim, do you have time for this?
It is a regression caused by patch 1 of bug 1470786. (Reverted that and the problem disappears)

I have looked through the code of GeckoEditableSupport but I'm not comfortable with it and feel I would not make great progress.
Flags: needinfo?(nchen)
See Also: → 1470786
Blocks: 1470786
See Also: 1470786
Jim or Kevin, does this bug affect Focus+GeckoView (62)? The bug that caused this regression (bug 1470786) affected GeckoView and its fix was uplifted to 62 Beta.
Whiteboard: [priority:medium] → [priority:medium][geckoview:klar]
I tried to fix losing IME selection when <input type="password"> masks the inputting character(s).
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c614d767c32f287077abb150227d3e50c9d7f2f5
However, password field input with IME is broken more by this bug... Looks like that Android widget inserts composition string again before selection?
Assignee: petru.lingurar → nobody
Status: ASSIGNED → NEW
Yeah I'll look.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Priority: -- → P1
Whiteboard: [priority:medium][geckoview:klar] → [priority:medium][geckoview:klar:p1]
Release Note Request (optional, but appreciated)
[Why is this notable]: Regression with some keyboards with a few dupes and some activity in the support forums.
[Affects Firefox for Android]: Only
[Suggested wording]: Duplicated first letter in some latin keyboards. Duplicated glyphs in Korean words. Using the Google keyboard is a workaround.
[Links (documentation, blog post, etc)]:
relnote-firefox: --- → ?
Added to our 63 release notes with the suggested wording. thanks
See Also: → 1493428
Duplicate of this bug: 1493428
Add a test for the text duplication bug caused by committing some text
and then immediately starting another composition.
If we already queued some synchronize replies, we should queue any
additional replies so that we don't prematurely reply to an event that
has not finished processing yet.

Also add delay for synchronize replies when a `OnImeUpdateComposition`
call is being processed.
Currently, we process replace-text events during `onTextChange` calls,
but we get confused if one `onTextChange` call corresponds to two or
more replace-text events. This patch makes us do minimal processing
during `onTextChange`, and perform the bulk of the processing during
each individual replace-text reply.
We may want to consider this for beta and release uplift.
I think for release (or even beta), a better option would be to back out bug 1470786 (with an exception for Focus because backing out that bug would regress text input in Focus).
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8fe5fe86bd9b
1. Add a test for text duplication bug; r=esawin
https://hg.mozilla.org/integration/mozilla-inbound/rev/386aba91a4b6
2. Queue synchronize replies if we already queued some replies; r=esawin
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff32e0590061
3. Process replace-text event on reply; r=esawin
ni to myself to file a followup bug for the backout
Flags: needinfo?(lhenry)
Duplicate of this bug: 1500740
Verified as fixed in the latest version of Nightly 65.0a1 (2018-11-12) with Samsung Galaxy S8 (Android 8.0).
The regressing patch was backed out of 63 and 64.
Verified as fixed on Release 63.0.2 and Beta 63.0b9 with Samsung Galaxy Note 8 (Android 8.0.0).

Thank you!
Status: RESOLVED → VERIFIED
Sorry, the device is Samsung Galaxy S8 (Android 8.0.0).
You need to log in before you can comment on or make changes to this bug.