Closed Bug 1490489 Opened 3 years ago Closed 3 years ago

"Warning: getUnicodeUrl failed to get a Unicode URL..." warning is missing space & final newline

Categories

(DevTools :: Shared Components, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1490497

People

(Reporter: dholbert, Assigned: zjz)

References

Details

STR:
 0. Start Firefox from the terminal.
 1. Set pref browser.dom.window.dump.enabled = true
 2. Open a new tab.
 3. Open DevTools console (F12 or Ctrl Shift K)
 4. Type into console:
       console.log(1);console.log(2);
   ...and hit enter.
 5. Look at your terminal.

ACTUAL RESULTS:
Your terminal contains this output:
=======
Warning: getUnicodeUrl failed to get a Unicode URL fromdebugger eval code, reason: TypeError: debugger eval code is not a valid URL.Warning: getUnicodeUrl failed to get a Unicode URL fromdebugger eval code, reason: TypeError: debugger eval code is not a valid URL.
=======

Notably:
 - There's a space missing between "from" and "debugger".
 - We've got two copies of the warning (from the two console.log() statements), but no newline separating them. (The first one ends with "URL." and then the second immediately starts "Warning")

EXPECTED RESULTS:
 - Space between "from" & "debugger"
 - Newline at the end.

Looks like there are two dump() statements in https://searchfox.org/mozilla-central/source/devtools/client/shared/unicode-url.js which both are affected by this issue. zjz, perhaps you'd be interested in taking this & fixing those up?
Summary: " → "Warning: getUnicodeUrl failed to get a Unicode URL..." warning is missing space & final newline
See Also: → 1490497
Thanks for the clear bug report, as well as the one in bug 1490497 .
Assignee: nobody → zjz
Status: NEW → ASSIGNED
Component: General → Shared Components
Priority: -- → P2
Sure!

Though they originally tracked subtly different issues, I'm now duping this to bug 1490497, because it has removed the dump() statements altogether, which addresses both issues.  i.e. there's nothing remaining to be done here. :)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1490497
You need to log in before you can comment on or make changes to this bug.