Closed Bug 1490496 Opened Last year Closed 10 months ago

expose XPCOM FFI for rkv

Categories

(Toolkit :: General, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: myk, Assigned: myk)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

To ease use of rkv in Firefox/Gecko, we should expose an XPCOM FFI to it.
Summary: expose general FFI for rkv → expose XPCOM FFI for rkv
What's RKV?
Flags: needinfo?(myk)
rkv is a Rust interface to the LMDB key-value storage engine.  We vendored it into mozilla-central in bug 1445451, and we're investigating its use to replace a variety of the bespoke engines and formats for persisting data in Firefox (as documented in https://github.com/mozilla/firefox-data-store-docs).
Flags: needinfo?(myk)
Priority: -- → P3
MozReview-Commit-ID: JnQzXG581DW
Comment on attachment 9010443 [details]
Bug 1490496 - implement XPCOM FFI for key-value storage

Lina Cambridge (she/her) [:lina] has approved the revision.
Attachment #9010443 - Flags: review+
Blocks: 1499237
Blocks: 1499238
Blocks: 1499252
Hey Myk, this has r+, should it land or is it waiting on other work?
Flags: needinfo?(myk)
(In reply to Jared Wein [:jaws] (Regression Engineering Owner for 65) (please needinfo? me) from comment #5)
> Hey Myk, this has r+, should it land or is it waiting on other work?

Good question!  Lina reviewed parts of the revision and gave r+, but this is still awaiting review of the rest of the revision from Nika, who is the overall (blocking) reviewer for the changes; so this isn't quite ready to land yet.

I'm not quite how best to represent that in this bug.  Perhaps the simplest solution would be to remove the review+ flag on the attachment, since the Phabricator revision <https://phabricator.services.mozilla.com/D6328> is the source of truth for review status.  If I remember correctly, we recently updated our Phabricator installation to no longer set Bugzilla review flags in part because they can be misleading, as they are in this case.
Flags: needinfo?(myk)
Comment on attachment 9010443 [details]
Bug 1490496 - implement XPCOM FFI for key-value storage

Yeah, that's where my confusion came from. I see now that it's waiting on Nika's review on phabricator. Thanks for the reply :)
Attachment #9010443 - Flags: review+
Duplicate of this bug: 1499237
Depends on: 1512541
Blocks: 1515094
Depends on: 1522609
Depends on: 1522614
Blocks: 1522638
Blocks: 1482608
Blocks: 1525392
Pushed by myk@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/466f9c24e749
implement XPCOM FFI for key-value storage r=nika,lina,mossop
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
See Also: → 1527769
Duplicate of this bug: 866238
You need to log in before you can comment on or make changes to this bug.