Closed Bug 1490497 Opened 3 years ago Closed 3 years ago

"Warning: getUnicodeUrl failed to get a Unicode URL..." warning-spam (from dump()) for every console.log() executed in DevTools console

Categories

(DevTools :: Shared Components, defect, P1)

defect

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: dholbert, Assigned: zjz)

References

Details

Attachments

(1 file)

Same STR as bug 1490489.  But this bug is about *the fact that we're logging* (and doing so once per line of output), whereas bug 1490489 is about the logging itself having some typos.

STR:
 0. Start Firefox from the terminal.
 1. Set pref browser.dom.window.dump.enabled = true
 2. Open a new tab.
 3. Open DevTools console (F12 or Ctrl Shift K)
 4. Type into console:
       console.log(1);console.log(2);
   ...and hit enter.
 5. Look at your terminal.

ACTUAL RESULTS:
Your terminal contains this output:
=======
Warning: getUnicodeUrl failed to get a Unicode URL fromdebugger eval code, reason: TypeError: debugger eval code is not a valid URL.Warning: getUnicodeUrl failed to get a Unicode URL fromdebugger eval code, reason: TypeError: debugger eval code is not a valid URL.
=======

If you have a lot of console.log(...) statements back to back, you'll get as many of these warnings as there were statements.

EXPECTED RESULTS:
No such warning cluttering up my terminal output.  We should be able to service console.log() statements from the DevTools Console ("debugger eval code") without spamming extra output to the terminal.


(This is particularly problematic in debug builds, where "dump()" is enabled by default.)
I wonder which would be a better solution to resolve this bug together with bug 1490489 ?

Simply dropping the dump as an one-off fix to both the two bugs, or specially filtering output from debugger evaluator from calling getUnicodeUrl?

What's your opinion, Nicolas?
Assignee: nobody → zjz
Status: NEW → ASSIGNED
Flags: needinfo?(nchevobbe)
I feel like we could get rid of the dump statement. Unless you think it brings any value ?
Flags: needinfo?(nchevobbe)
Comment on attachment 9008338 [details]
Bug 1490497 - Drops the dump warning statements in the unicode-url.js because sometimes they produce unnecessary dumps. r?nchevobbe

Nicolas Chevobbe [:nchevobbe] has approved the revision.
Attachment #9008338 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e01560aa7d1
Drops the dump warning statements in the unicode-url.js because sometimes they produce unnecessary dumps. r=nchevobbe
Component: General → Shared Components
Priority: -- → P1
Duplicate of this bug: 1490489
https://hg.mozilla.org/mozilla-central/rev/4e01560aa7d1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.