Open Bug 1490546 Opened Last year Updated 3 months ago

Intermittent [tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL

Categories

(Core :: DOM: Service Workers, defect, P3)

defect

Tracking

()

REOPENED

People

(Reporter: intermittent-bug-filer, Assigned: apavel)

References

(Regression)

Details

(Keywords: intermittent-failure, leave-open, Whiteboard: [stockwell disabled])

Attachments

(3 files)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=198751595&repo=mozilla-central

https://queue.taskcluster.net/v1/task/C7Yp5wYuRMOuptpAwcbRFA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-09-11T23:26:50.799Z] 23:26:50     INFO - TEST-START | /service-workers/service-worker/postmessage.https.html
[task 2018-09-11T23:26:51.171Z] 23:26:51     INFO - 
[task 2018-09-11T23:26:51.171Z] 23:26:51     INFO - TEST-PASS | /service-workers/service-worker/postmessage.https.html | postMessage to a ServiceWorker (and back via MessagePort) 
[task 2018-09-11T23:26:51.172Z] 23:26:51     INFO - TEST-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client 
[task 2018-09-11T23:26:51.172Z] 23:26:51     INFO - TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL
[task 2018-09-11T23:26:51.172Z] 23:26:51     INFO - TEST-INFO | expected FAIL
[task 2018-09-11T23:26:51.172Z] 23:26:51     INFO - .
[task 2018-09-11T23:26:51.172Z] 23:26:51     INFO - TEST-OK | /service-workers/service-worker/postmessage.https.html | took 374ms
[task 2018-09-11T23:26:51.188Z] 23:26:51     INFO - PID 17713 | 1536708411184	Marionette	INFO	Stopped listening on port 2828
[task 2018-09-11T23:26:51.204Z] 23:26:51     INFO - PID 17713 | JavaScript error: resource://activity-stream/lib/TopSitesFeed.jsm, line 86: TypeError: setting getter-only property "_currentSearchHostname"
[task 2018-09-11T23:26:51.533Z] 23:26:51     INFO - Browser exited with return code 0
[task 2018-09-11T23:26:51.534Z] 23:26:51  WARNING - u'runner_teardown': ()
[task 2018-09-11T23:26:51.552Z] 23:26:51     INFO - Setting up ssl
[task 2018-09-11T23:26:51.580Z] 23:26:51     INFO - certutil | 
[task 2018-09-11T23:26:51.617Z] 23:26:51     INFO - certutil | 
[task 2018-09-11T23:26:51.638Z] 23:26:51     INFO - certutil | 
[task 2018-09-11T23:26:51.639Z] 23:26:51     INFO - Certificate Nickname                                         Trust Attributes
[task 2018-09-11T23:26:51.639Z] 23:26:51     INFO -                                                              SSL,S/MIME,JAR/XPI
[task 2018-09-11T23:26:51.639Z] 23:26:51     INFO - 
[task 2018-09-11T23:26:51.639Z] 23:26:51     INFO - web-platform-tests                                           CT,, 
[task 2018-09-11T23:26:51.639Z] 23:26:51     INFO - 
[task 2018-09-11T23:26:51.709Z] 23:26:51     INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmpeDaz_i.mozrunner
[task 2018-09-11T23:26:51.730Z] 23:26:51     INFO - Starting runner
[task 2018-09-11T23:26:56.073Z] 23:26:56     INFO - PID 18905 | 1536708416069	Marionette	INFO	Listening on port 2828
[task 2018-09-11T23:26:56.365Z] 23:26:56     INFO - TEST-START | /service-workers/service-worker/ready.https.html
[task 2018-09-11T23:26:56.385Z] 23:26:56     INFO - Setting pref dom.streams.enabled (true)
[task 2018-09-11T23:26:56.422Z] 23:26:56     INFO - Setting pref javascript.options.streams (true)
[task 2018-09-11T23:26:56.468Z] 23:26:56     INFO - Setting pref dom.serviceWorkers.enabled (true)
[task 2018-09-11T23:26:57.180Z] 23:26:57     INFO - PID 18905 | JavaScript error: https://web-platform.test:8443/service-workers/service-worker/ready.https.html, line 123: InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable
[task 2018-09-11T23:26:57.181Z] 23:26:57     INFO - PID 18905 | JavaScript error: https://web-platform.test:8443/service-workers/service-worker/ready.https.html, line 152: InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable
[task 2018-09-11T23:26:57.189Z] 23:26:57     INFO - .........
[task 2018-09-11T23:26:57.191Z] 23:26:57     INFO - TEST-OK | /service-workers/service-worker/ready.https.html | took 827ms
Summary: Intermittent TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL → Intermittent PermaOrange Tier 2 TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL
Summary: Intermittent PermaOrange Tier 2 TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL → Intermittent PermaOrange QR Tier 2 TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 10 months ago4 months ago
Regressed by: 1558851
Resolution: --- → INCOMPLETE
Summary: Intermittent PermaOrange QR Tier 2 TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL → Perma [tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL

Test failure and the failure rate goes down (was 0.005 -> 0.024 -> 0.018). Mark as P5 for now.

Priority: -- → P5

The test failure rate has increased since this week and all of them are on Android. Mark this as P3 now.

Perry, maybe you have idea what's going on here? Or, is there a meta bug on service worker for tracking failure tests with higher priorities?

Flags: needinfo?(perry)
Priority: -- → P3
Summary: Perma [tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL → Intermittent[tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL
Summary: Intermittent[tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL → Intermittent [tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/postmessage.https.html | postMessage a transferable ArrayBuffer between ServiceWorker and Client over MessagePort - expected FAIL
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a38fa70468c
update postmessage.https.html.ini expectation r=jmaher
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → apavel

(In reply to Tom Tung [:tt, :ttung] from comment #16)

The test failure rate has increased since this week and all of them are on Android. Mark this as P3 now.

Perry, maybe you have idea what's going on here? Or, is there a meta bug on service worker for tracking failure tests with higher priorities?

Based on the error being TypeError: r.installing is null from the second subtest and the first subtest's SW having the same scope as the second subtest's SW, I'd guess that it might be because the registration from the first subtest is being re-used ("resurrected") in the second subtest, so that registration's worker has already passed the installing phase. Disabling that behavior is bug 1557244.

Flags: needinfo?(perry)

(In reply to Perry Jiang [:perry] from comment #24)

Based on the error being TypeError: r.installing is null from the second subtest and the first subtest's SW having the same scope as the second subtest's SW, I'd guess that it might be because the registration from the first subtest is being re-used ("resurrected") in the second subtest, so that registration's worker has already passed the installing phase. Disabling that behavior is bug 1557244.

Thanks for the explanation! It seems that this might be fixed in bug 1557244 or the failure log might change after that bug. Thus, marking the dependency on this issue.

Depends on: 1557244
Status: RESOLVED → REOPENED
Flags: needinfo?(jmaher)
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---

this seems intermittent, can we disable it on android and e10s ?

Flags: needinfo?(jmaher)
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled}
Whiteboard: [stockwell disabled} → [stockwell disabled]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d06aaf60e0d
disable postmessage.https.html on android debug r=jmaher
Keywords: checkin-needed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.