Closed Bug 1490552 Opened 2 years ago Closed 2 years ago

The setting of Tracking Protection is inconsistent between the conventional setting and the setting in the Hamburger Menu

Categories

(Firefox :: Protections UI, defect)

62 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: apple.macintosh.farm, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180830143136

Steps to reproduce:

Using Firefox 62.0 on Mac OS  ( macOS Sierra 10.12.6 ( on a MacBook Air) )

About Tracking Protection setting. The setting behavior in the Hamburger Menu added in Firefox 62 is different from the conventional setting.

There are three states in the setting in the conventional Menu.
On the other hand, setting in the Hamburger Menu can be set to two states individually in the Normal Window and the Private Window.There are a total of four setting states as Firefox .
In other words, it is inconsistent.

1) Change Tracking Protection setting from conventional setting.

2) Check the setting of Tracking Protection in Hamburger Menu at Normal window and Private window.

3) Now change the Tracking Protection setting in the Hamburger Menu.
Set it at Normal window and Private window respectively.

4) Then, confirm the setting state in conventional setting .


Actual results:

The result is as follows.

------------------------------------------------------------------------------------------------------
Tracking Protection setting    ==>      Hamburger Menu                    Hamburger Menu
  of conventional setting                 at Normal Windows          /      at Private Windows
------------------------------------------------------------------------------------------------------
Always                         ==>      Tracking Protection ; ON     /    Tracking Protection ; ON

Only in private windows        ==>      Tracking Protection ; OFF    /    Tracking Protection ; ON

Never                          ==>      Tracking Protection ; OFF    /    Tracking Protection ; OFF



------------------------------------------------------------------------------------------------------
Hamburger Menu                    Hamburger Menu                 ==>       Tracking Protection setting
  at Normal Windows          /      at Private Windows                       of conventional setting
------------------------------------------------------------------------------------------------------
Tracking Protection ; ON     /    Tracking Protection ; ON       ==>        Always

Tracking Protection ; OFF    /    Tracking Protection ; ON       ==>        Only in private windows

Tracking Protection ; OFF    /    Tracking Protection ; OFF      ==>        Never


But ...

Tracking Protection ; ON     /    Tracking Protection ; OFF      ==>        Always


Expected results:

When protection is enabled in the Normal Window, gray out with switch enabled in order to make it impossible to change in the Private Window.
Component: Untriaged → Tracking Protection
Summary: The setting of Tracking Protectoin is inconsistent between the conventional setting and the setting in the Hamburger Menu → The setting of Tracking Protection is inconsistent between the conventional setting and the setting in the Hamburger Menu
Johann, should this be a WONTFIX since the toggle has been replaced with a different one in 63 already?
Blocks: 1490388
Flags: needinfo?(jhofmann)
Blocks: privacy-ui
No longer blocks: 1490388
It advertises to enable TP for the current browsing mode by default, looks good to me and is a success: https://data.firefox.com/dashboard/usage-behavior
(At least it doesn't advertise to disable a lax Tracking Protection like it's implemented in Firefox 63 and onwards.)
Yes we were aware of this inconsistency when we implemented it and decided that we think it will not have a major impact on the user experience.

The toggle became an entirely different thing in 63, for better or worse, and so I agree that this is probably a WONTFIX. From conversations so far it seems like we will stick with the Content Blocking UI vs. the old TP UI no matter what happens with FastBlock.

If, against all odds, the TP UI will continue to stick around for longer than 63 or 64 we could revisit this decision but at the moment this bug is not actionable.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jhofmann)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.