Closed Bug 1490811 Opened Last year Closed Last year

Add a permission doorhanger for storage access

Categories

(Firefox :: Protections UI, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox65 --- verified

People

(Reporter: tcinotto, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy65])

Attachments

(4 files)

No description provided.
Component: DOM → Tracking Protection
Product: Core → Firefox
Target Milestone: mozilla64 → Firefox 64
First, we need a design.  Do we need a separate design bug?
Flags: needinfo?(rfeeley)
Whiteboard: [privacy-panel-64] → [privacy-panel]
This is the preliminary design: https://mozilla.invisionapp.com/share/HVOAH7KGAJU#/screens

For privacy reasons we're not going to show the favicons by default, but rather offer the user to expand the popup to view the sites.
Blocks: privacy-ui
Flags: needinfo?(rfeeley)
Priority: P1 → P2
Summary: UI for Storage Access Permissions (Door hanger UI) → Add a permission doorhanger for storage access
Whiteboard: [privacy-panel] → [privacy65]
Depends on: 1506014
Depends on: 1484876
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Depends on: 1507677
No longer depends on: 1484876
Depends on: 1508657
Depends on: 1508758, 1508759
Attached image Screenshot
(The icons aren't final yet, I have yet to receive the final ones from Bryan.)
This first part should be ready for review.  It is fully functional and is only missing automated tests.  For now, this patch shows a prompt every time, the heuristics for showing the prompt less frequently will be implemented later in a follow-up.
See Also: → 1509047
This test checks the functionality of the prompt using the utilities of
the antitracking test suite.  It provides a complete end-to-end test
for the functionality of the prompts integrated with the API, including
the necessity to interact with a tracker and implicitly ensuring we do
not show a prompt in that case too.

Depends on D12507
Depends on: 1510015
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e3bf28192df
Part 1: Add a permission doorhanger for the storage access API r=baku,johannh
https://hg.mozilla.org/integration/autoland/rev/f2bf86926c65
Part 2: Add a test for the basic functionality of the storage access prompt r=johannh
https://hg.mozilla.org/integration/autoland/rev/0c537d7bf40a
Part 3: Add an automated end-to-end integration test for the functionality of the storage access prompt r=baku
Depends on: 1510723
On Nighlty 65.0a1 (2018-12-04), the doorhanger is not working. Is there a special pref that should be modified/added or we should reopen this issue?
Flags: needinfo?(jhofmann)
Flags: needinfo?(ehsan)
(In reply to David Olah from comment #10)
> On Nighlty 65.0a1 (2018-12-04), the doorhanger is not working. Is there a
> special pref that should be modified/added or we should reopen this issue?

I've added documentation about all of the respective prefs in this doc for you as we had discussed in the kick-off meeting (on Oct 29).

In particular I think it is the automatic granting of storage access which causes the prompts to not show up, so if you set the dom.storage_access.auto_grants pref to false it should disable that behaviour and you should see the doorhanger prompts after that.  You should look at that doc for more complete explanation around what these prefs do.
Flags: needinfo?(ehsan)
Depends on: 1512385
Depends on: 1513021
Depends on: 1512625
Flags: needinfo?(jhofmann)

We covered this through our Cookie Restriction feature test plan, and we can confirm that the door hanger works as intended on Beta 65.0b10, under Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
No longer depends on: 1558503
Regressions: 1558503
Regressions: 1577558
You need to log in before you can comment on or make changes to this bug.