When choosing save when prompted to handle a file, the file does not actually get saved

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: bugs, Assigned: law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020604
BuildID:    2002060408

Went to my site as usual to grab my windows export of the much prettier icon for
unix.
Since my default for files is binary, I was prompted to either choose a handler,
or save.  I chose save.  Browsed for where to save it, clicked ok.  Everything
went away.
No download manager, nothing on disk.
Choosing save-as from menu still works fine.

Reproducible: Always
Steps to Reproduce:
1. go to a url like the one given
2. choose to save the file
3. er, look for non-existent file on disk?

Actual Results:  no saved file

Expected Results:  saved a file to disk
(Reporter)

Comment 1

17 years ago
Tried stepping back one build to 0604
Following occurred.  Clicking on file once again didn't work, but when I chose
Save as, it started up the d/l manager and cranking away.  then the followin
error popped up:
C:\temp\mozilla-win32-installer-sea.exe could not be saved, because an unknown
error occurred.
Sorry about that.  Try saving to a different location.

This happened at 
9824KB of 10668KB
Machine has half a gig of validated DDR memory, and 59.5 gigs of hard drive
space free. Seems unlikely it ran out of anything.
Reporter:
Have you enough space in the temp directory ?

-> File Handling
Assignee: Matti → law
Component: Browser-General → File Handling
QA Contact: imajes-qa → sairuh
(Reporter)

Comment 3

17 years ago
Now that's odd.
Tried downloading again, this time 060308
This time, I was away, so the error message that popped up again got ignored.
However, download manager reported the file successfully downloaded.
Size checks out and installer seems happy with it and whatever sum checks it did.
(Reporter)

Comment 4

17 years ago
regarding your question, Matthias, see the portion of that comment where I
mentioned 59.5 gigs free on that partition... (the only one on this windows machine)
(Reporter)

Comment 5

17 years ago
Fell back to 2002060308
All saving works correctly once more.
Did not delete profile, so whatever is wrong, was wrong with the browser.
Also, the problem with 2002060408 continued even after a reboot.
O.S. is 98 S.E.
QA Contact: sairuh → petersen
(Reporter)

Comment 6

13 years ago
No longer seems to be an issue.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.