Inconsistent layout for CSS tables

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Quinn Yost (mythdraug), Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
I have a 5x5 table, defined to be 640px by 480px.
The first element in each row and col is defined
to be 20% of the table.  Occasionally, the table 
will be stretched one direction or the other.

build: 2002060408 win32
(Reporter)

Comment 1

16 years ago
Created attachment 86278 [details]
Correct layout
(Reporter)

Comment 2

16 years ago
Created attachment 86279 [details]
Incorrect layout
(Reporter)

Comment 3

16 years ago
It appears I can force the incorrect layout by changing the
window's width.  Correct layout can then be restored by 
reloading the page.
(Reporter)

Updated

16 years ago
Summary: Inconsistant layout for CSS tables → Inconsistent layout for CSS tables
Re: Comment #3 From Quinn Yost (mythdraug) 2002-06-04 14:04
> It appears I can force the incorrect layout by changing the window's width.
> Correct layout can then be restored by reloading the page.

Confirming this:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020609

Updated

16 years ago
Priority: -- → P3
-> HTMLTables
Assignee: attinasi → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → amar
Target Milestone: --- → Future
(Reporter)

Comment 6

16 years ago
Created attachment 88867 [details]
Initial testcase

BZ: While this is not as minimal a testcase as you requested,
  I did find what is likely the cause of the layout inconsistancy.

table def:  640 x 480 px
First element of each row is defined to have height 20%
First element of each col is defined to have width 20%

Cell 2.2 is rowspan 3, colspan 3, and (here's the likely culprit)
 320 x 320 px.
Umm... I can't reproduce this any longer with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020619
How do I tell when the layout is wrong with the minimal testcase?

As a note, the original site now worksforme (build 2002-06-24-08) and I _did_
use to see the problem there...
(Reporter)

Comment 9

16 years ago
While the testcase had layout problems, the original page
had identical issues.

However, I will agree that the layout of the page is
now consistent.

Marking WFM.   It wasn't so much that the page didn't
layout as I expected (my layout miscalculation), it 
was that it did so irregularly.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.