Javascript:winclose() should close only the current tab

CLOSED DUPLICATE of bug 103452

Status

--
enhancement
CLOSED DUPLICATE of bug 103452
17 years ago
10 years ago

People

(Reporter: djst, Assigned: jag-mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you open a pop-up window in a new tab and then press the Close button (which
normally uses the "Javascript:winclose()" command), the whole Mozilla window
will close.

Javascript:winclose() should always close only the current tab, since a Mozilla
window can contain more than one open web page. The site invoking the command
can never tell how many web pages are loaded in the window.

Comment 1

17 years ago
I don't know the winclose() function. The most likely option is that it's a
regular function defined within the site that simply calls window.close() to
close the window. Googling reveals that "winclose" is indeed a name very often
used for such a function on various javascript tutorial sites.
In which case I'm duping this correctly.

If however winclose turns out to be some special javascript function (perhaps
for the close button on our tab bar?) and there's more to this bug than I see,
do speak up.

*** This bug has been marked as a duplicate of 32571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Yes, this is probably the same as window.close().

I can't believe Bugilla returned Zarro Boogs when I searched it for
window.close()!! Sorry about the duplicate.

Comment 3

17 years ago
np. :)
Actually I duped this against the wrong (though related) bug as well. Sorry for
the spam.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 103452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

16 years ago
.
Status: VERIFIED → CLOSED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.