Closed Bug 1491121 Opened Last year Closed Last year

Weird window corner behavior with gfx.compositor.glcontext.opaque

Categories

(Core :: Widget: Cocoa, defect)

defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox64 --- affected

People

(Reporter: Dolske, Unassigned)

References

Details

Attachments

(1 file)

Attached video corner-weirdness.mov
I just toggled it on to try after mconley suggested it, and noticed it acts oddly. Expected, or bug?

See attached screencast (this is right after a restart with the pref enabled). The titlebar corners are still round, but not always, and movign the mouse around sometimes makes the corner size/radius expand and shrink. Hard to notice unless zoomed in, so not a very big deal.

The bottom corners seem to have a more obvious result, still rounded but over a black background, which seems expected to me. I don't see them changing size.
Expected. Corner weirdness + vibrancy is the reason why we don't set the pref by default, and why we're working on using CoreAnimation instead.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
Duplicate of this bug: 1528490
You need to log in before you can comment on or make changes to this bug.