Closed Bug 1491264 Opened 2 years ago Closed 1 year ago

Intermittent TEST-UNEXPECTED-PASS | /css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html

Categories

(Core :: Graphics: WebRender, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

Details

(Keywords: intermittent-failure)

Filed by: cbrindusan [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=199273595&repo=mozilla-central

https://queue.taskcluster.net/v1/task/C-nlrnmsS-ujrKcQxCOfQw/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/C-nlrnmsS-ujrKcQxCOfQw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

[task 2018-09-14T11:04:39.971Z] 11:04:39     INFO - TEST-START | /css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html
[task 2018-09-14T11:04:39.972Z] 11:04:39     INFO - PID 13910 | 1536923079969	Marionette	INFO	Testing http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html == http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002-ref.html
[task 2018-09-14T11:04:39.988Z] 11:04:39     INFO - PID 13910 | ++DOMWINDOW == 100 (0x7f387ab4b800) [pid = 14042] [serial = 179] [outer = 0x7f3894556800]
[task 2018-09-14T11:04:40.065Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 101 (0x7f387ad50800) [pid = 14042] [serial = 180] [outer = 0x7f3894556800]
[task 2018-09-14T11:04:40.102Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a32e800 == 16 [pid = 14042] [id = {462b1333-01b2-437b-88af-c894b7d5bfed}]
[task 2018-09-14T11:04:40.102Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 102 (0x7f38795b8e00) [pid = 14042] [serial = 181] [outer = (nil)]
[task 2018-09-14T11:04:40.102Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 103 (0x7f387a648400) [pid = 14042] [serial = 182] [outer = 0x7f38795b8e00]
[task 2018-09-14T11:04:40.111Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a949000 == 17 [pid = 14042] [id = {97912c5c-8c01-4136-a5bb-1fbb5b3028ed}]
[task 2018-09-14T11:04:40.112Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 104 (0x7f38795b9400) [pid = 14042] [serial = 183] [outer = (nil)]
[task 2018-09-14T11:04:40.112Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 105 (0x7f387ad53800) [pid = 14042] [serial = 184] [outer = 0x7f38795b9400]
[task 2018-09-14T11:04:40.121Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a946000 == 18 [pid = 14042] [id = {f5aeae51-d5cc-4a6c-a987-f74217f3bc74}]
[task 2018-09-14T11:04:40.121Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 106 (0x7f387b04c000) [pid = 14042] [serial = 185] [outer = (nil)]
[task 2018-09-14T11:04:40.121Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 107 (0x7f387ad51800) [pid = 14042] [serial = 186] [outer = 0x7f387b04c000]
[task 2018-09-14T11:04:40.129Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a946800 == 19 [pid = 14042] [id = {170ab136-1c60-499f-a38e-a5d7be2db46e}]
[task 2018-09-14T11:04:40.129Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 108 (0x7f387b04dc00) [pid = 14042] [serial = 187] [outer = (nil)]
[task 2018-09-14T11:04:40.130Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 109 (0x7f387ad54000) [pid = 14042] [serial = 188] [outer = 0x7f387b04dc00]
[task 2018-09-14T11:04:40.139Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a94c000 == 20 [pid = 14042] [id = {a957d090-7c17-4e7b-ad29-4fff502a8ca8}]
[task 2018-09-14T11:04:40.140Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 110 (0x7f387b04da00) [pid = 14042] [serial = 189] [outer = (nil)]
[task 2018-09-14T11:04:40.140Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 111 (0x7f387ad54400) [pid = 14042] [serial = 190] [outer = 0x7f387b04da00]
[task 2018-09-14T11:04:40.148Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a947800 == 21 [pid = 14042] [id = {f2f577c6-fa88-41f1-8335-9ca6af1211fa}]
[task 2018-09-14T11:04:40.149Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 112 (0x7f38795b7000) [pid = 14042] [serial = 191] [outer = (nil)]
[task 2018-09-14T11:04:40.149Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 113 (0x7f387ad54800) [pid = 14042] [serial = 192] [outer = 0x7f38795b7000]
[task 2018-09-14T11:04:40.157Z] 11:04:40     INFO - PID 13910 | ++DOCSHELL 0x7f387a948000 == 22 [pid = 14042] [id = {0c41b0bb-3d2e-4f92-9dec-e7e32598c63e}]
[task 2018-09-14T11:04:40.158Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 114 (0x7f387b04e600) [pid = 14042] [serial = 193] [outer = (nil)]
[task 2018-09-14T11:04:40.158Z] 11:04:40     INFO - PID 13910 | ++DOMWINDOW == 115 (0x7f387ad54c00) [pid = 14042] [serial = 194] [outer = 0x7f387b04e600]
[task 2018-09-14T11:04:40.339Z] 11:04:40     INFO - TEST-UNEXPECTED-PASS | /css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html | Testing http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html == http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002-ref.html
The failure rate here seems to have increased starting with the 19th of December, failing on windows10-64-qr mostly or linux64-qr

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=218739817&repo=autoland&lineNumber=8703

02:26:39     INFO - TEST-START | /css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html
02:26:39     INFO - PID 4804 | 1545704799425	Marionette	INFO	Testing http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html == http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002-ref.html
02:26:39     INFO - PID 4804 | 1545704799650	Marionette	INFO	No differences allowed
02:26:39     INFO - TEST-UNEXPECTED-PASS | /css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html | Testing http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002e.html == http://web-platform.test:8000/css/vendor-imports/mozilla/mozilla-central-reftests/images3/object-position-svg-002-ref.html

02:26:39     INFO - TEST-INFO expected FAIL | took 272ms
02:26:39     INFO - PID 4804 | [Child 1364, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:39     INFO - PID 4804 | [Child 1364, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:39     INFO - PID 4804 | 1545704799801	Marionette	INFO	Stopped listening on port 2828
02:26:39     INFO - PID 4804 | [Parent 6872, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:39     INFO - PID 4804 | [Child 1384, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Parent 6872, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Child 7808, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Child 7808, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Parent 6872, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Child 4604, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [Child 4604, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | [GPU 1056, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 332
02:26:40     INFO - PID 4804 | ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
02:26:40     INFO - PID 4804 | ###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv
02:26:40     INFO - Browser exited with return code 0
02:26:40     INFO - PROCESS LEAKS None
02:26:40     INFO - Closing logging queue
02:26:40     INFO - queue closed
02:26:40     INFO - Setting up ssl
02:26:40     INFO - certutil | 
02:26:40     INFO - certutil | 
02:26:40     INFO - certutil | 
02:26:40     INFO - Certificate Nickname                                         Trust Attributes
02:26:40     INFO -                                                              SSL,S/MIME,JAR/XPI
02:26:40     INFO - 
02:26:40     INFO - web-platform-tests                                           CT,, 
02:26:40     INFO - 
02:26:41     INFO - Application command: Z:\task_1545704103\build\application\firefox\firefox.exe -marionette about:blank --wait-for-browser -profile c:\users\task_1545704103\appdata\local\temp\tmp7fs2ij.mozrunner
02:26:41     INFO - Starting runner
02:26:41     INFO - PID 524 | 1545704801691	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid host permission: resource://pdf.js/
02:26:41     INFO - PID 524 | 1545704801691	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid host permission: about:reader*
02:26:43     INFO - PID 524 | WARN: compileToBinary(235):
02:26:43     INFO - PID 524 | C:\fakepath(196,14-129): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
02:26:43     INFO - PID 524 | C:\fakepath(202,58-112): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
02:26:44     INFO - PID 524 | 1545704804433	Marionette	INFO	Listening on port 2828


seems to be caused by bug 1425592:

https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C10%2Cx64%2Cquantumrender%2Copt%2Cweb%2Cplatform%2Ctests%2Cwith%2Ce10s%2Ctest-windows10-64-qr%2Fopt-web-platform-tests-reftests-e10s-4%2Cw-e10s%28wr4%29&tochange=3e8d6cb4fd38bfea0ebbc2555c6ca9ef60175038&fromchange=cc290b5855ebbf80801a08f2d57ebefed1d7eeb7&selectedJob=218446907

:Kats, please take a look at this too.
Flags: needinfo?(kats)
Assignee: nobody → kats
Blocks: 1425592
Component: CSS Parsing and Computation → Graphics: WebRender
Flags: needinfo?(kats)
The reftest version of this test is consistently failing and is marked fails-if(webrender). Since it is intermittently passing in the WPT harness out seems like a bug on the WPT harness, same as https://bugzilla.mozilla.org/show_bug.cgi?id=1463827#c5
See Also: → 1463827
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d3f43a88c709
Disable test on webrender for high frequency intermittents. r=me
https://hg.mozilla.org/mozilla-central/rev/d3f43a88c709
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.