Closed Bug 1491268 Opened Last year Closed Last year

Bookmarks policy's last fields are displayed with a different background color

Categories

(Firefox :: Enterprise Policies, defect, P2, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- verified
firefox64 --- verified

People

(Reporter: emilghitta, Assigned: arshadkazmi42, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(3 files)

Attached image AboutPolicies.png
[Affected versions]:
Firefox 63.0b6 (BuildId:20180913141435)
Firefox 64.0a1 (BuildId:20180913100107)

[Affected platforms]:
Windows 10 64bit.
Ubuntu 16.04 64bit.
macOS 10.13.6

[Preconditions]
Enable the "Bookmarks" policy (with the "Folder" field completed) via the JSON or GPO.

[Steps to reproduce]:
1. Launch Firefox.
2. Access the about:policies#active page.

[Expected result]:
The Bookmarks policy fields are displayed under a dark gray background.

[Actual result]:
All the Bookmarks active policy information is displayed under a dark gray background except for the "Folder" information (which is displayed under a white background).

[Notes]
For further information regarding this issue please observe the attached screenshot.
Please note that this is reproducible only with the last fields for the Bookmarks policy (Reproducible with Favicon or Placement fields as well if they are the last fields for the Bookmark policy).
I didn't managed to reproduce this under other policies (I will try investigating this further).
Attached file policies.json
This policies.json file reproduces the problem
The last row is missing the "odd" color class. I haven't verified the fix, but looking at the code, this seems to be the only case where the color class might accidentally not be added to the row: https://searchfox.org/mozilla-central/rev/dd965445ec47fbf3cee566eff93b301666bda0e1/browser/components/enterprisepolicies/content/aboutPolicies.js#166

so I bet that's the problem there
Mentor: felipc
Keywords: good-first-bug
Priority: -- → P2
i was looking into this, and trying to reproduce it. I am not sure about this

> [Preconditions]
> Enable the "Bookmarks" policy (with the "Folder" field completed) via the JSON or GPO.


Where can i find this options?
Flags: needinfo?(felipc)
Hello Arshad,

take a look at the beginning of this README file here: https://github.com/mozilla/policy-templates/blob/master/README.md

You need to add a policies.json file to an specific folder inside the Firefox install dir. I already included one example policies.json file in this bug, so what you need to do is to download it and put it in the right location.

After you've done that, to verify that things are working correctly, you can:

- open about:support and see if it says that "Enterprise Policies" are "Active"
- open about:policies to see if the Bookmarks policy was picked up, and see the problem described in this bug
Flags: needinfo?(felipc)
Assignee: nobody → arshadkazmi42
Status: NEW → ASSIGNED
Comment on attachment 9013069 [details]
Bug 1491268 - Bookmarks policy's last field is displayed in same color like all other rows

:Felipe Gomes (needinfo me!) has approved the revision.
Attachment #9013069 - Flags: review+
Pushed by fgomes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b79da889f39b
Bookmarks policy's last field is displayed in same color like all other rows r=Felipe
https://hg.mozilla.org/mozilla-central/rev/b79da889f39b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
This issue is verified fixed using Firefox 64.0a1 (BuildId:20181002220140) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 16.04.64bit.
Status: RESOLVED → VERIFIED
Comment on attachment 9013069 [details]
Bug 1491268 - Bookmarks policy's last field is displayed in same color like all other rows

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1465942

User impact if declined: about:policies visual polish

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: (QE has already tested it)

List of other uplifts needed: none

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Simple CSS classes fix

String changes made/needed: none
Attachment #9013069 - Flags: approval-mozilla-beta?
Comment on attachment 9013069 [details]
Bug 1491268 - Bookmarks policy's last field is displayed in same color like all other rows

Minimal CSS patch fixing a P2 and verified on nightly, uplift approved for 63 beta 12, thanks.
Attachment #9013069 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This issue is verified fixed using Firefox 63.0b12 (BuildId:20181004174654) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 18.04 64bit.
You need to log in before you can comment on or make changes to this bug.