Closed Bug 1491269 Opened Last year Closed 9 months ago

TEST-UNEXPECTED-FAIL | [snip]/mozmill/views/testTaskView.js - Take 1

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jorgk-bmo, Assigned: darktrojan)

References

Details

(Whiteboard: [Thunderbird-testfailure: Z all][Thunderbird-disabled-test])

Attachments

(4 files, 2 obsolete files)

This newly enabled test fails intermittently:
TEST-UNEXPECTED-FAIL | /Users/cltbld/tasks/task_1536922515/build/tests/mozmill/views/testTaskView.js | testTaskView.js::testTaskView

Some timing problem:
https://taskcluster-artifacts.net/DR-AotJmRgO-sygOWlTx6w/0/public/logs/live_backing.log

INFO -  SUMMARY-UNEXPECTED-FAIL | testTaskView.js | testTaskView.js::testTaskView
INFO -    EXCEPTION: waitFor: Timeout exceeded for '() => {
INFO -          countAfterDelete = taskTreeNode.mTaskArray.length;
INFO -          return countAfter - 1 == countAfterDelete;
INFO -      }'
INFO -      at: utils.js line 396
INFO -         TimeoutError utils.js:396 13
INFO -         waitFor utils.js:434 11
INFO -         MozMillController.prototype.waitFor controller.js:687 3
INFO -         testTaskView testTaskView.js:153 5
Flags: needinfo?(geoff)
Attached patch 1491269-task-view-delete-1.diff (obsolete) — Splinter Review
Going to run this on Try a bunch of times, and if it passes, get review. I'm not positive this will actually fix things.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Well, that didn't help.
Whiteboard: [Thunderbird-testfailure: Z Mac] → [Thunderbird-testfailure: Z Linux, Mac]
Unassigning myself in case somebody else wants to have a go.
Assignee: geoff → nobody
Status: ASSIGNED → NEW
Try looks green, and wasn't without it. So let's do this. Not 100% sure if it's just checking sometimes wrong numbers due to the double delete, or what. 

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=c8693bbe868b6ab639b4a2caad9438dc56bcb7ec
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9026368 - Flags: review?(geoff)
Attachment #9012014 - Attachment is obsolete: true
Comment on attachment 9026368 [details] [diff] [review]
bug1491269_testTaskView.patch

Review of attachment 9026368 [details] [diff] [review]:
-----------------------------------------------------------------

I never understood what that was all about. Let's try this and see what happens.
Attachment #9026368 - Flags: review?(geoff) → review+
Geoff, if you check this in, let's do a better commit message, like:
Bug 1491269 - Fix test failure in testTaskView.js by avoiding double delete. r=darktrojan

I can't see you on IRC, hence NI.
Flags: needinfo?(geoff)
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/73d35ac1dec4
Fix test failure in testTaskView.js by avoiding double delete; r=darktrojan
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Flags: needinfo?(geoff)
Target Milestone: --- → 6.6
Target Milestone: 6.6 → 6.7
INFO -  SUMMARY-UNEXPECTED-FAIL | testTaskView.js | testTaskView.js::testTaskView
INFO -    EXCEPTION: Task did not delete; countBefore=1, countAfter=1
INFO -      at: utils.js line 396
INFO -         TimeoutError utils.js:396 13
INFO -         waitFor utils.js:452 11
INFO -         MozMillController.prototype.waitFor controller.js:687 3
INFO -         testTaskView testTaskView.js:160 5

That's around the code that was changed.
Seems like an oversight not to remember the previous count *before* clicking
Attachment #9029406 - Flags: review?(geoff)
I don't think that change will make any difference, but it does read better. Why not make countBefore = taskTreeNode.mTaskArray.length instead of relying on a value from further up the code?
The difference it could make is that if the delete is really fast then the before value would be the after value -> of course no changes after that.
Attachment #9029406 - Attachment is obsolete: true
Attachment #9029406 - Flags: review?(geoff)
Attachment #9029782 - Flags: review?(geoff)
Attachment #9029782 - Flags: review?(geoff) → review+
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0e2cd56c3a6c
Follow-up: fix testTaskView.js failure by remembering the number of tasks before clicking delete; r=darktrojan
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Still failing:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&selectedJob=215893431&revision=5b8c49b90a556e79ff6cdf0eaf929646c643adbd

EXCEPTION: Task did not delete; countBefore=1, countAfter=1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This test is perma-red after bug 1482389 hit us, so I'm taking it out for now.

Error is:
EXCEPTION: Expression "[2]" returned null. Anonymous == false
at: elementslib.js line 455
reduceLookup elementslib.js:455 15
Lookup.prototype.getNode elementslib.js:501 10
MozMillController.prototype.assertJSProperty controller.js:1026 17
testTaskView testTaskView.js:146 5

Flags: needinfo?(geoff)
Whiteboard: [Thunderbird-testfailure: Z Linux, Mac] → [Thunderbird-testfailure: Z all][Thunderbird-disabled-test]
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0ecdef42a8cb
disable failing test testTaskView.js. rs=bustage-fix

Working on this at the moment, I think I know what's wrong. With the new bustage, at least.

Flags: needinfo?(geoff)
Assignee: mkmelin+mozilla → geoff
Attachment #9036838 - Flags: review?(philipp)
Comment on attachment 9036838 [details] [diff] [review]
1491269-task-view-test-1.diff

Review of attachment 9036838 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the fix!
Attachment #9036838 - Flags: review?(philipp) → review+
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/1c626f1c70ef
Fix failing testTaskView.js; r=Fallen

If I could, I'd set the status to RESOLVED MAYBE⁈⁉

Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: 6.7 → 6.8
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1522605

I'm getting confused, let's have a new bug.

Status: REOPENED → RESOLVED
Closed: 11 months ago9 months ago
Resolution: --- → FIXED
Summary: TEST-UNEXPECTED-FAIL | [snip]/mozmill/views/testTaskView.js → TEST-UNEXPECTED-FAIL | [snip]/mozmill/views/testTaskView.js - Take 1
You need to log in before you can comment on or make changes to this bug.