Closed Bug 14913 Opened 21 years ago Closed 21 years ago

the ? on a CGI with no arguments gets stripped

Categories

(Core :: DOM: HTML Parser, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jer, Assigned: gagan)

References

()

Details

Steps to reproduce:
Using build id #1999092408 and/or M9 on Win 98, try going to above URL.

Results:
The question mark at the end of the URL is stripped, resulting in an error 404.

Expected:
Successful load of url, returning html + images to client.

Builds tested:
viewer & apprunner on both 1999092408 and M9.

Thoughts:
Any chance that this is partly due to the cgi not ending with .cgi  ? This isn't
related to bug 14333, which looks fixed.
adding http:// to url.
This is an urlparser problem, should be assiged to gagan

The problem is: the ? is found, but is not part of the url as it is stored in
nsStdURL. The ? gets integrated into the url if there is a querypart beside the
?. Since here is none, the ? gets stripped in ReconstructPath.

A solution would be to have all the delimiter chars like ;?# inside the URL
components. This would also reduce the appends in ReconstructSpec/Path. See
http://bugzilla.mozilla.org/show_bug.cgi?id=11677
cc'ing gagan

just for the fun I did another heavy rewrite of nsStdURL.cpp. It works now for
me, but I have to test this further.
Assignee: rickg → gagan
Gagan -- the URL parsing stuff is yours, right? Please send this back to me
if I've misassigned it.
Status: NEW → ASSIGNED
Depends on: 13449
adding dep. and taking over.
No longer depends on: 13449
Blocks: 13449
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Target Milestone: M11
verified
2000-09-15-08-M18
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.