Closed Bug 1491334 Opened 11 months ago Closed 6 months ago

Crash in java.lang.NoClassDefFoundError: ch.boye.httpclientandroidlib.impl.DefaultHttpResponseFactory at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.createHttpResponseFactory(AbstractHttpClientConnection.java)

Categories

(Firefox for Android :: General, defect, critical)

Firefox 63
Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox62 --- unaffected
firefox63 --- wontfix

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-98c28d83-8b9f-4197-962c-1f6a20180914.
=============================================================

Seen while looking at 63 beta crash stats - this crash appears to only be affecting 2 versions of the Verizon tablet - QTAIR7 and QTAQZ3: https://bit.ly/2MuDCv3. Looks as if crashes started in B3.

Pushlog from B3: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml

Comments:
* you guys sent an update. Now its crashing 
* crashing!!! won't even load on tablet. please fix. 

Java stack trace:

java.lang.NoClassDefFoundError: ch.boye.httpclientandroidlib.impl.DefaultHttpResponseFactory
	at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.createHttpResponseFactory(AbstractHttpClientConnection.java:151)
	at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.init(AbstractHttpClientConnection.java:232)
	at ch.boye.httpclientandroidlib.impl.SocketHttpClientConnection.bind(SocketHttpClientConnection.java:148)
	at ch.boye.httpclientandroidlib.impl.conn.DefaultClientConnection.openCompleted(DefaultClientConnection.java:138)
	at ch.boye.httpclientandroidlib.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:183)
	at ch.boye.httpclientandroidlib.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:145)
	at ch.boye.httpclientandroidlib.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:131)
	at ch.boye.httpclientandroidlib.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:611)
	at ch.boye.httpclientandroidlib.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:446)
	at ch.boye.httpclientandroidlib.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:860)
	at ch.boye.httpclientandroidlib.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
	at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java:308)
	at org.mozilla.gecko.sync.net.BaseResource.go(BaseResource.java:373)
	at org.mozilla.gecko.sync.net.BaseResource.post(BaseResource.java:404)
	at org.mozilla.gecko.sync.net.BaseResource.postBlocking(BaseResource.java:547)
	at org.mozilla.gecko.telemetry.TelemetryUploadService.uploadPayload(TelemetryUploadService.java:155)
	at org.mozilla.gecko.telemetry.TelemetryUploadService.uploadPendingPingsFromStore(TelemetryUploadService.java:122)
	at org.mozilla.gecko.telemetry.TelemetryUploadService.onHandleWork(TelemetryUploadService.java:80)
	at android.support.v4.app.JobIntentService$CommandProcessor.doInBackground(JobIntentService.java:391)
	at android.support.v4.app.JobIntentService$CommandProcessor.doInBackground(JobIntentService.java:382)
	at android.os.AsyncTask$2.call(AsyncTask.java:292)
	at java.util.concurrent.FutureTask.run(FutureTask.java:237)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
	at java.lang.Thread.run(Thread.java:818)
Adding a similar signature seen in 63.
Crash Signature: [@ java.lang.NoClassDefFoundError: ch.boye.httpclientandroidlib.impl.DefaultHttpResponseFactory at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.createHttpResponseFactory(AbstractHttpClientConnection.java)] → [@ java.lang.NoClassDefFoundError: ch.boye.httpclientandroidlib.impl.DefaultHttpResponseFactory at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.createHttpResponseFactory(AbstractHttpClientConnection.java)] [@ java.lang.ArrayIndexOutOfBo…
Crash Signature: java.lang.ArrayIndexOutOfBoundsException: at ch.boye.httpclientandroidlib.impl.EnglishReasonPhraseCatalog.setReason(EnglishReasonPhraseCatalog.java)] → java.lang.ArrayIndexOutOfBoundsException: at ch.boye.httpclientandroidlib.impl.EnglishReasonPhraseCatalog.setReason(EnglishReasonPhraseCatalog.java)] [@ java.lang.NoClassDefFoundError: at ch.boye.httpclientandroidlib.impl.AbstractHttpClientConnection.cr…
Device is not available on RemoteTestKit. Device is available on ebay.

Mfg.     Device    Version    Architecture   #
quanta   QTAQZ3    22 (REL)   armeabi-v7a    37 60.7%
quanta   QTAIR7    22 (REL)   armeabi-v7a    24 39.3%
Susheel is this a tablet we could get for QA/developer investigation? It seems like a lot of crashes, therefore a lot of users. It is an older API but may be worth looking into.
Flags: needinfo?(sdaswani)
No-Jun, maybe that question is for you about obtaining this tablet.
Flags: needinfo?(nojun.park)
Updated device count from the largest volume signature:

quanta 	QTAIR7 	22 (REL) 	armeabi-v7a 	2251 	51.7%
quanta 	QTAQZ3 	22 (REL) 	armeabi-v7a 	2059 	47.3%
sts 	TAB-A03-BS 	22 (REL) 	armeabi-v7a 	44 	1.0%
sts 	TAB-A03-BR 	22 (REL) 	armeabi-v7a 	1 	0.0%
tottori 	TAB-A03-BS 	22 (REL) 	armeabi-v7a 	44 	1.0%
tottori 	TAB-A03-BR 	22 (REL) 	armeabi-v7a 	1 	0.0%
I defer to No-Jun on getting the device.
Flags: needinfo?(sdaswani)
We also have the option of no longer supporting this 5 year old tablet that runs Android 5.1. We can exclude it from the play store interface. 

Andreas, what do you think? Older tablets are still available for around $100 or cheaper.
Flags: needinfo?(abovens)
Would require two devices one of them going to the SV developers. This is not enough of a priority from the Engineering side. Willing to reconsider if Andreas wants to fix this. Given that it seems to be a crash on page load blocking the devices seems fine.
Flags: needinfo?(nojun.park)
OK, I'm going with unsupporting the device. If anyone disagrees just let me know.
Excluded on release: QTAIR7, QTAQZ3.
There are two devices listed under TAB-A03 that should be blocked as well. Benesse TAB-A03-BS and Sts-tottori TAB-A03 which are the same device as the Quanta.
Flags: needinfo?(lhenry)
OK, TAB-A03-BS and TAB-A03 are both blocked now.  Neither appeared to have any active installs. Thanks Kevin!
Flags: needinfo?(lhenry)

No crashes since 63.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
Flags: needinfo?(abovens)
You need to log in before you can comment on or make changes to this bug.