Closed Bug 14915 Opened 21 years ago Closed 21 years ago

Bad looking border edges+

Categories

(Core :: Layout, defect, P3)

x86
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 12462

People

(Reporter: tapio.markula, Assigned: dcone)

References

()

Details

C22 spesification 17 Table, 17.5.2
!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
  <HEAD>
    <STYLE type="text/css">
      TABLE { background: #ff0; border-collapse: collapse }
      TD    { background: red; border: double black }
    </STYLE>
  </HEAD>
  <BODY>
    <P>
    <TABLE>
      <TR>
        <TD> 1
        <TD rowspan="2"> 2
        <TD> 3
        <TD> 4
      </TR>
      <TR><TD></TD></TR>
    </TABLE>
  </BODY>
</HTML>
This doesn't look out good.  I put termination tags to it and tested:
http://www.nic.fi/~tapio1/Teaching/Model25.html
Anyway it doesn' look out as in the
picture in the spesification page.
Mozilla can't make continuous border edges. MS IE 5.0 makes
45 degree angle, which looks good.
Especially border-style:double looks bad if borders are uncontinous
But it can't make also continuous borders (it cuts
 them on the right and it can't display as the CSS2 pages shows).
Assignee: troy → dcone
Don, this is probably a DUP of an existing bug
This is probably a duplicate of bug 12462.  The collapsing border model border
code is a mess... (see also bug 3000 and bug 2436, and the beveling is bad too)
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
I think this has to do with table cell size, etc, as in bug #12462, and borders
are being rendered over each other.  Marking as duplicate

*** This bug has been marked as a duplicate of 12462 ***
I fixed the crash on the url.
Status: RESOLVED → VERIFIED
Marking as duplicate of 14915.
You need to log in before you can comment on or make changes to this bug.