saving incorrect password in imap or pop mail saves it without alerting you that it is incorect, can't recover gracefully

VERIFIED DUPLICATE of bug 94775

Status

--
major
VERIFIED DUPLICATE of bug 94775
17 years ago
11 years ago

People

(Reporter: esther, Assigned: mscott)

Tracking

Trunk
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using branch builds 20020603 on winxp and linux (haven't tested mac yet) if you
type in an incorrect password and click the remember this password, the
incorrect password is saved even though the server brings back an alert telling
the IMAP user  "log into sever failed"  and the POP user "invalid login".  
Unfortunately, this results in the user having to find out how to remove that
incorrectly remembered password via Password Manager in order to get the
password dialog again.  If the user doesn't realize they gave an incorrect
password, they have no clue as to why it's failing and won't even check the
password manager.

This is bad and results in vague feedback saying I can't log into my mail.
This needs to be fixed.  We shouldn't remember the password until the sever
successfully logs in.

Updated

17 years ago
QA Contact: gayatri → esther
Whiteboard: nsbeta1
(Reporter)

Comment 1

17 years ago
1. launch app
2. create a new mail account and type in the wrong password checking the box to
save it.

Result:  you will get a login failed type message with no indication you gave
the incorrect password or a new password dialog to try again.  
Expected: to give a new password dialog after notifying the user of the
incorrect login.
Note: this happens to the other types of mail accounts as reported in bugscape
but I can't find that bug right now, but this bug is specific to non-web mail
accounts.
This one of the top feedback problems and I agree we should fix it.
Summary: saving incorrect imap or pop mail saves it without alerting you that it is incorect, can't recover gracefully → saving incorrect password in imap or pop mail saves it without alerting you that it is incorect, can't recover gracefully

Comment 3

17 years ago
Cavin or Navin, is this a dup of one of the password bugs you've recently fixed?

Comment 4

17 years ago
i think the fix is in bug 121926

Comment 5

17 years ago
I believe this is a dup of bug 94775 whose fix is only in the trunk right now.
Esther, can you try the lastest trunk build and see if the behavior is what you
expect? Thanks.

Updated

17 years ago
Keywords: nsbeta1
Whiteboard: nsbeta1
(Reporter)

Comment 6

17 years ago
Cavin, Karen did check the trunk builds and verified them as fixed, so we'll
wait for it to be checked into the branch to retest it.  Marking dup and verifying

*** This bug has been marked as a duplicate of 94775 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.