Closed Bug 1491776 Opened Last year Closed Last year

Typing a non-alpha character insert it after the completion text for a brief moment

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(3 files)

**Steps to reproduce**
1. Open the console
2. Type `doc`
3. The completion text should be visible (with `ument`.
4. Type `;`

**Actual results**

For a very brief moment, the input looks like `document;` (where `ument` is in grey), before switching to `doc;`.
This results in a flash of styling which looks weird (see attachment).

---

This is probably because of the way we use markText in the editor.
Attached image screenshot of the issue
Here's a still of what's visible just after typing `;`. It's only displayed for some milliseconds.
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Depends on: 1470922
Comment on attachment 9009579 [details]
Bug 1491776 - Do not use markText to show the completion text; r=bgrins.

Brian Grinstead [:bgrins] has approved the revision.
Attachment #9009579 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83af3bf2f967
Do not use markText to show the completion text; r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/83af3bf2f967
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Regressions: 1558248
You need to log in before you can comment on or make changes to this bug.