Closed Bug 1491792 Opened 6 years ago Closed 4 years ago

Tracking protection breaks CTA search navigation on realestate.com.au

Categories

(Web Compatibility :: Site Reports, defect, P3)

Firefox 64
x86_64
All
defect

Tracking

(firefox64 affected)

RESOLVED WORKSFORME
Tracking Status
firefox64 --- affected

People

(Reporter: alberts, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-analytics])

User Story

adobedtm.com

Attachments

(2 files)

1) In Nightly set Content Blocking to "Slow loading tracker" & "All Detected trackers" to "blocking"
2) Go to https://www.realestate.com.au/buy (redirected from https://www.realestate.com.au)
3) Under "Search properties for sale" are some red and dark grey navigation buttons, just after the big search form; click any of them

I get a JS error: 
uncaught exception: Tried to load omniture library, but s_code has not been loaded yet

When I switch off content blocking it works fine
Priority: -- → P3
Summary: Content Blocking breaks CTA search navigation on realestate.com.au → Tracking protection breaks CTA search navigation on realestate.com.au
Whiteboard: tp-needsrepro
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://widgets.outbrain.com/outbrain.js” was blocked because content blocking is enabled.
The resource at “https://dpm.demdex.net/id?d_visid_ver=2.4.0&d_fieldgroup=AAM&d_rtbd=json&d_ver=2&d_orgid=341225BE55BBF7E17F000101%40AdobeOrg&d_nsid=0&d_mid=58279408479182157824589982445880905447&d_blob=RKhpRz8krg2tLO6pguXWp5olkAcUniQYPHaMWWgdJ3xzPWQmdj0y&d_cid_ic=AVID%012DD130A48531419A-6000012B00000DDF&ts=1537368697705” was blocked because content blocking is enabled.
The resource at “https://assets.adobedtm.com/e5959eaf55fcfb3773bc2b809a9741c6d33e5156/scripts/satellite-5ac30ae864746d532200dd31.js” was blocked because content blocking is enabled.
The resource at “https://cdn-gl.imrworldwide.com/ci/realestate.json” was blocked because content blocking is enabled.
The resource at “https://secure-au.imrworldwide.com/storageframe.html” was blocked because content blocking is enabled.
The resource at “https://static.hotjar.com/c/hotjar-673993.js?sv=6” was blocked because content blocking is enabled.
The resource at “https://content.aimatch.com/default.gif” was blocked because content blocking is enabled.
The resource at “https://widgets.outbrain.com/outbrain.js” was blocked because content blocking is enabled.
The resource at “https://cdn.krxd.net/controltag?confid=JCgamYdi” was blocked because content blocking is enabled.
The resource at “https://js-agent.newrelic.com/nr-768.min.js” was blocked because content blocking is enabled.
The resource at “https://secure-assets.rubiconproject.com/utils/rea/reatag.min.js” was blocked because content blocking is enabled.
The resource at “https://ads.rubiconproject.com/prebid/9607_pb.js” was blocked because content blocking is enabled.
The resource at “https://z.moatads.com/reagroup87581475204/moatad.js#moatClientLevel1=263&moatClientLevel2=44468&moatClientLevel3=316105&moatClientLevel4=662443&moatClientSlicer1=rea&moatClientSlicer2=specialoffers&zMoatPosttags=null&zMoatPlatform=web&zMoatSize=990x125&zMoatVW=https%3A%2F%2Fsasinator%2Erealestate%2Ecom%2Eau%2Frea%2Fcount%2FFCID%3D662443%2FACT%3D4%2Fviewid%3D1537368697666%2Fsite%3Drea%2Farea%3Dbuy%2Ehomepage%2Fproptype%3Dnull%2Fstate%3Dnull%2Frandom%3D4630662398%2Fadtype%3Dsafeframe%2Fpos%3Dspecialoffers%2Fsize%3D990x125&zMoatArea=buy.homepage” was blocked because content blocking is enabled.
The resource at “https://ad.doubleclick.net/ddm/trackimpi/N6492.128483.REALESTATE.COM.AU/B20126581.205798316;dc_trk_aid=405614892;dc_trk_cid=93285576;ord=4947618;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?” was blocked because content blocking is enabled.

So below are the domains to test:
- ​widgets.outbrain.com
- dpm.demdex.net
- assets.adobedtm.com
- cdn-gl.imrworldwide.com
- secure-au.imrworldwide.com
- static.hotjar.com
- content.aimatch.com
- widgets.outbrain.com
- cdn.krxd.net
- js-agent.newrelic.com
- secure-assets.rubiconproject.com
- ads.rubiconproject.com
- z.moatads.com
- ad.doubleclick.net

I opened the URL in a fresh browser profile (Firefox Nightly 64, uMatrix installed, normal mode) and loaded the page. The "Search" categories are not functional.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- adobedtm.com (including all related domains)
and the "Search" categories could be selected.

The other resources didn't help. 

So in conclusion:
- adobedtm.com is in Analytics category = [tp-anaytics]
Blocks: tp-breakage
User Story: (updated)
Component: Tracking Protection → Desktop
OS: Unspecified → Windows 10
Product: Firefox → Tech Evangelism
Hardware: Unspecified → x86_64
Whiteboard: tp-needsrepro → [tp-analytics]
Version: 64 Branch → Firefox 64
Added screenshot with "Search" category selection not functional.
Attached image umatrixResults.png
Added uMatrix results.
OS: Windows 10 → All
Product: Tech Evangelism → Web Compatibility

The buttons are now working for me in strict mode (and with custom mode where all cookies are blocked+trackers) so this seems to have been fixed.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: