Closed Bug 1491828 Opened 3 years ago Closed 3 years ago

Poor performance with AV1 decoder

Categories

(Core :: Audio/Video: Playback, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED

People

(Reporter: jya, Unassigned)

References

(Blocks 1 open bug)

Details

Looking at the various Bitmovin AV1 demo, we can see that lots of frames are dropped.
Chrome will display those streams just fine on the same machine.

Looking quickly over a profiler, it appears that libaom is only using a single thread to perform the decoding, leading to poor performance

Should investigate what's going on...
Turned out the AOM decoder doesn't have parallel frames decoding anymore, and the video encoding is made of one slice only, so it can only be decoded on a single thread.

That doesn't explain however why performance with Chrome was so much better, same with a Edge beta bit moving got with av1 support
Blocks: AV1
Priority: -- → P2
Can you try again now that this has landed?

https://bugzilla.mozilla.org/show_bug.cgi?id=1489285

Aside from a more recent libaom, it uses the 8-bit path for 8-bit video, which should double performance.
Duplicate of this bug: 1493517

The bitmovin sample plays flawlessly with dav1d now.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.