Pages without <BODY> crash NGLayout

VERIFIED DUPLICATE of bug 1487

Status

()

Core
Layout
P1
critical
VERIFIED DUPLICATE of bug 1487
19 years ago
18 years ago

People

(Reporter: Angus Davis, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This page works fine:
<body>
Foo<p>Bar</body>

This page crashes NGLayout:
Foo<p>Bar

I'm using 11-21-98 4pm debug bits. Could this bug be related to bug 1487 or
vice versa? Directory listings from http://grok/test/ do not include a <body>
tag.

Here is the stack trace:
NTDLL! 77f76148()
nsDebug::Assertion(const char * 0x00650ee8, const char * 0x00650ecc, const char
* 0x00650e9c, int 176) line 95 + 13 bytes
RootFrame::Reflow(RootFrame * const 0x00fa9f34, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 176 + 37 bytes
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x00fac640,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsSize & {...},
nsIRenderingContext & {...}) line 163
PresShell::ProcessReflowCommands() line 725
PresShell::ExitReflowLock(PresShell * const 0x00fab130) line 429
PresShell::ContentAppended(PresShell * const 0x00fab138, nsIDocument *
0x00faa3e0, nsIContent * 0x00fa831c, int 0) line 853
nsDocument::ContentAppended(nsDocument * const 0x00faa3e0, nsIContent *
0x00fa831c, int 0) line 873
HTMLContentSink::DidBuildModel(HTMLContentSink * const 0x00fabf60, int 1) line
1355
CNavDTD::DidBuildModel(CNavDTD * const 0x00fa8c40, int 0, int 1) line 644 + 20
bytes
nsParser::DidBuildModel(int 0) line 505 + 44 bytes
nsParser::OnStopBinding(nsParser * const 0x00faa054, nsIURL * 0x00faafc0, int
0, const nsString & {...}) line 918 + 15 bytes
nsDocumentBindInfo::OnStopBinding(nsDocumentBindInfo * const 0x00fa91e0, nsIURL
* 0x00faafc0, int 0, const nsString & {...}) line 1482 + 30 bytes
OnStopBindingProxyEvent::HandleEvent(OnStopBindingProxyEvent * const
0x00fa8fb0) line 570
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x00fa8fb4) line 452 + 12
bytes
PL_HandleEvent(PLEvent * 0x00fa8fb4) line 408 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ec9f60) line 370 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0237097a, unsigned int 49369, unsigned int 0,
long 15507296) line 701 + 9 bytes
USER32! 77e71250()
00ec9f60()

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
So why did you give 1487 to me, and 1492 to Kipp? This is indeed a DUP and
something must have changed in the parser

*** This bug has been marked as a duplicate of 1487 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
Verified as a dup.
You need to log in before you can comment on or make changes to this bug.