Closed Bug 1492008 Opened 4 years ago Closed 4 years ago

Remove --theme-*-image variables

Categories

(DevTools :: General, enhancement, P2)

enhancement

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: ntim, Assigned: fvsch)

References

Details

Attachments

(1 file)

Those were originally introduced as we supported the Firebug theme which had different images than the default themes.

They're not really useful anymore, and I suspect removing them could actually lead to perf improvements. Variables on :root cause unnecessary whole document restyles when changed, see bug 1435122.
Severity: normal → enhancement
Priority: -- → P2
I started working on this a bit, and removing the few image variables in variables.css is easy enough.

There are a lot of images defined in other stylesheets, a few can be removed but I probably won't do a complete pass.
Assignee: nobody → florens
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d43466f74cb3
Remove devtools --theme-*-image CSS variables; r=ntim
https://hg.mozilla.org/mozilla-central/rev/d43466f74cb3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Depends on: 1517986
You need to log in before you can comment on or make changes to this bug.