errors compiling mozilla1 rc3 with --enable-toolkit-qt

VERIFIED DUPLICATE of bug 144469

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 144469
16 years ago
13 years ago

People

(Reporter: Mike Gardiner, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
when compiling mozilla 1 rc3 with the --enable-qt flag ( to enable to qt toolkit ) the build refused to 
complete at nsFontMetricsQT.cpp as follows: 
 
nsFontMetricsQT.cpp:614: syntax error before `(' 
nsFontMetricsQT.cpp:631: cannot declare member function `nsFontMetricsQT::nsFontMetricsQT' within `QFont' 
nsFontMetricsQT.cpp:631: syntax error before `{' 
nsFontMetricsQT.cpp:638: syntax error before `++' 
 
< from  
 
nsFontMetricsQT.cpp:639: warning: ANSI C++ forbids declaration `mDeviceContext' with no type 
to 
nsFontMetricsQT.cpp:657: warning: ANSI C++ forbids declaration `mUserDefinedFont' with no type 
 
there are similar errors on the lines in between > 
 
then: 
 
nsFontMetricsQT.cpp:658: parse error before `}' 
nsFontMetricsQT.cpp:661: cannot declare member function `nsFontMetricsQT::nsFontMetricsQT' within `QFont' 
nsFontMetricsQT.cpp:661: syntax error before `{' 
 
< followed by more forbids declaration errors > 
 
until: 
 
nsFontMetricsQT.cpp: In method `class nsFontQT * nsFontMetricsQT::LoadFont(QString &, short unsigned 
int)': 
nsFontMetricsQT.cpp:1094: no matching function for call to `QFontDatabase::charSets (QString &, const 
bool &)' 
nsFontMetricsQT.cpp: In method `class QFont * nsFontMetricsQT::LoadQFont(QString &, const QString &)': 
nsFontMetricsQT.cpp:1306: `CharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1306: parse error before `;' 
nsFontMetricsQT.cpp:1311: no matching function for call to `QFont::charSet ()' 
nsFontMetricsQT.cpp:1311: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1312: `charset' undeclared (first use this function) 
nsFontMetricsQT.cpp:1312: (Each undeclared identifier is reported only once 
nsFontMetricsQT.cpp:1312: for each function it appears in.) 
nsFontMetricsQT.cpp:1312: `getExtendedCharSet' undeclared (first use this function) 
nsFontMetricsQT.cpp:1313: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1346: no matching function for call to `QFont::charSet ()' 
nsFontMetricsQT.cpp:1346: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1348: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1367: no matching function for call to `QFont::charSet ()' 
nsFontMetricsQT.cpp:1367: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp:1369: `AnyCharSet' is not a member of type `QFont' 
nsFontMetricsQT.cpp: In function `static nsresult nsFontMetricsQT::FamilyExists(const nsString &)': 
nsFontMetricsQT.cpp:1404: no matching function for call to `QFontDatabase::charSets (QString, const bool  
nsFontMetricsQT.cpp: In method `class nsFontQT * nsFontMetricsQT::FindGlobalFont(short unsigned int)': 
nsFontMetricsQT.cpp:1565: no matching function for call to `QFontDatabase::charSets (QString &, const 
bool &)' 
nsFontMetricsQT.cpp: In method `nsresult nsFontQTNormal::GetBoundingMetrics(const PRUnichar *, unsigned 
int, nsBoundingMetrics &)': 
nsFontMetricsQT.cpp:1782: warning: comparison between signed and unsigned 
nsFontMetricsQT.cpp: In method `nsresult nsFontQTUserDefined::GetBoundingMetrics(const PRUnichar *, 
unsigned int, nsBoundingMetrics &)': 
nsFontMetricsQT.cpp:1998: warning: comparison between signed and unsigned 
nsFontMetricsQT.cpp: In function `nsresult EnumFonts(nsIAtom *, const char *, PRUint32 *, PRUnichar 
***)': 
nsFontMetricsQT.cpp:2052: no matching function for call to `QFontDatabase::charSets (QString &, const 
bool &)' 
../../../dist/include/string/nsBufferHandle.h: At top level: 
nsFontMetricsQT.cpp:78: warning: `int gFontMetricsQTCount' defined but not used 
make[5]: *** [nsFontMetricsQT.o] Error 1 
 
at which point the compilation fails make[5] - make[1]. 
 
i have reproduced this error several times, using both the ./configure script with the 
--enable-toolkit-qt and qt set as the default toolkit, as well as by using the ~/.mozconfig script made 
with the config builder helper (found off the mozilla.org/build/unix.html instructions) 
 
qt version is 3.0.3, and using kde 3.0.0. 
linux is 2.4.17 
xfree86 is 4.2.0 
gcc is 2.95 (not gcc3) 
 
hope this helps.

Comment 1

16 years ago
Marking as a duplicate of bug 144469(PATCH: --enable-toolkit-qt Doesn't build
with Qt 3.x).  You should also check bug 144216(mozilla 1.0rc2 doesn't build
with --enable-toolkit-qt).  

If you apply the patches in those bugs, Mozilla should build with Qt.  I'm sure,
the bug owners would appreciate any feedback you have.  

*** This bug has been marked as a duplicate of 144469 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.