copying link from source view adds "source-view:" to link

VERIFIED FIXED in Firefox 65

Status

()

defect
P5
normal
VERIFIED FIXED
8 months ago
4 months ago

People

(Reporter: felix.bau, Assigned: JanH)

Tracking

Trunk
Firefox 66
All
Android
Points:
---

Firefox Tracking Flags

(firefox64 wontfix, firefox65 verified, firefox66 verified)

Details

Attachments

(1 attachment)

Reporter

Description

8 months ago
User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:62.0) Gecko/62.0 Firefox/62.0
Build ID: 20180906142540

Steps to reproduce:

I opened a page and then opened source view (html)


Actual results:

I wanted to copy a link's address so I did that

the url in my clipboard had "source-view:" add the beginning


Expected results:

this could be intentional, but I would like it to be different

if you click on it, then Firefox should open the link in source view

if you copy the link's address over the context menu, then you should only get the link without "source-view:" at the beginning of it

what do you think?
https://dxr.mozilla.org/mozilla-central/rev/85b4d2bf888afa32b67638602a3338d0a6935ff9/browser/base/content/nsContextMenu.js#1300-1306 needs porting over to the mobile context menu implementation.
Assignee: nobody → jh+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
Desktop does this when copying link URLs and sharing is just effectively just
another form of copying.
For completeness, we also apply this when "viewing" the source of images (which
just displays the image itself anyway).

No special handling is required for other media elements (audio/video), because
looking at those in view-source mode does display the raw file contents and
thus none of the media-specific context menu entries will show up.

Comment 3

5 months ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/531e57a2941f
Strip view-source prefix when copying/sharing links from context menu. r=snorp

Comment 4

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/531e57a2941f
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Did you want to nominate this for Beta uplift?
Flags: qe-verify+
Flags: needinfo?(jh+bugzilla)
Comment on attachment 9033329 [details]
Bug 1492335 - Strip view-source prefix when copying/sharing links from context menu. r?snorp

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: View source on Android

User impact if declined: Copying a link from the context menu while in a view-source: tab copies the link including the view-source:-prefix, which apparently is not consistent with what Desktop does.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: none

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): We're simply stripping off the view-source:-prefix in the context menu handler, which is very similar to the way this is done in Desktop Firefox.

String changes made/needed: none
Flags: needinfo?(jh+bugzilla)
Attachment #9033329 - Flags: approval-mozilla-beta?

Comment 7

5 months ago
I could reproduce this issue on Android Firefox 64.0.1. 


I verified this bug fix on Android Firefox 66.0a1 (2018-12-28), issue is no longer reproducible. I will verify on beta 65 after the fix gets uplifted to beta.
Comment on attachment 9033329 [details]
Bug 1492335 - Strip view-source prefix when copying/sharing links from context menu. r?snorp

[Triage Comment]
Avoids copying the view-source: prefix when copying a link while viewing the page source. Approved for 65.0b8.
Attachment #9033329 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 10

4 months ago

I verified this bug fix on Android Firefox 65.0b13, issue is no longer reproducible.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.