Closed Bug 1492360 Opened 4 years ago Closed 4 years ago

High CPU usage when open firefox before chrome/chromium

Categories

(Core :: Layout: Text and Fonts, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1495900

People

(Reporter: vbnm123c, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180917143811

Steps to reproduce:

1. Open Firefox (v63)
2. Open Chrome/Chromium (v69)

Change the order will not happen

Here is the video: https://youtu.be/xZYJmMQRWzE
Here is the perf record (clean profile): https://perfht.ml/2OBfZmf
Here is another perf record (default profile): https://perfht.ml/2NScXNn

Environment:
OS: Linux Mint 18.3 Sylvia x86_64
Kernel: 4.15.0-33-generic

$ firefox --version
Mozilla Firefox 63.0
$ google-chrome --version
Google Chrome 69.0.3497.100


Actual results:

VERY HIGH CPU usage 10~30 seconds


Expected results:

Not so long CPU usage
Hello Mike, could you please look into the performance report here? Thanks!
Flags: needinfo?(mconley)
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Sorry for the delay. From this profile (https://perfht.ml/2EnGkUh), it looks like we're burning a bunch of CPU asking for the OS for font information. ni?ing jfkthame who might know more.
Component: JavaScript Engine → Layout: Text and Fonts
Flags: needinfo?(mconley) → needinfo?(jfkthame)
This looks like a dupe of bug 1495900; updating the system to fontconfig 2.13 would probably help considerably. It's not clear to me that there's much we can directly do about this, given that the update seems to be triggered from inside GTK...
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → DUPLICATE
Duplicate of bug: 1495900
You need to log in before you can comment on or make changes to this bug.