Closed Bug 1492460 Opened 2 years ago Closed 2 years ago

UX: Display the deprecation warnings in the new about debugging

Categories

(DevTools :: about:debugging, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1505132

People

(Reporter: ochameau, Unassigned)

References

(Blocks 1 open bug)

Details

WebIDE currently displays two warnings when connecting to a remote runtime:
  https://searchfox.org/mozilla-central/source/devtools/client/webide/content/webide.js#718-730

1) One when connecting to a remote using a server more recent than the frontend:
The connected runtime has a more recent build date (%1$S) than your desktop Firefox (%2$S) does. This is an unsupported setup and may cause DevTools to fail. Please update Firefox.

2) Another one when connecting to an old, unsupported server:
The connected runtime has an old version (%1$S). The minimum supported version is (%2$S). This is an unsupported setup and may cause DevTools to fail. Please update the connected runtime.
See Also: → 1487337
I wonder if we could take the opportunity to update the strings to make them consistent. One warning is talking about build dates and the other one is talking about versions.

If both strings are in about:debugging, it should be an easy fix, I think :)
Priority: -- → P3
Priority: P3 → P2
Summary: Display the deprecation warnings in the new about debugging → UX: Display the deprecation warnings in the new about debugging
(From bug 1505795)

When a new Firefox for Android is released, it is not immediately available to all users, the rollout seems to be progressive.

For instance, Firefox for Android 63 was released on the Oct 23 2018. Today Nov 08 2018, I still get Firefox for Android 62 on the play store.

Connecting to this version from Nightly triggers the backward compatibility warning from WebIDE (and from about:debugging when we will implement it).

The rollout usually takes just a few days, but when there is an issue with a release, it can be blocked and take several weeks. We should keep that in mind when implementing this.
Duplicate of this bug: 1505795
No longer blocks: 1505132

Already implemented in 1505132

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1505132
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.