[Website Testing] www.gopher.com crashing chimera

VERIFIED FIXED

Status

Camino Graveyard
General
--
blocker
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Lance Olson, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Nav. Ver. 0.3.0 (NB 6/4/02)
OS X Ver. 10.1.5

Testing Website: www.gopher.com

Along left hand side of site, a link (joke of the day) opens another window 
at a new website that is still branded as gopher but is at (http://
www.100hot.com/todays_joke/gopher_joke2.gsp) when this window is 
closed the browser crashes. I have re-created this multiple times, and 
allways does this.

I cannot figure how to attach the crash log, so I'm afraid I do need to paste 
it here:
**********

Date/Time:  2002-06-05 03:47:26 -0700
OS Version: 10.1.5 (Build 5S60)

Command:    Navigator
PID:        367

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x7d9b03e7

Thread 0:
 #0   0x7350cf04 in UnlockPortBits
 #1   0x734ed440 in CopyBits
 #2   0x026b33fc in 
CopyBitsWithMask__10nsImageMacP6BitMapn1sPB1RC4Rectn2i
 #3   0x026b2c40 in DrawToImage__10nsImageMacP8nsIImagein3
 #4   0x03d64d18 in DrawTo__13gfxImageFrameP14gfxIImageFramein3
 #5   0x03160a70 in 
DoComposite__12imgContainerPP14gfxIImageFrameP6nsRectii
 #6   0x03160820 in Notify__12imgContainerP8nsITimer
 #7   0x00236adc in Fire__11nsTimerImpl
 #8   0x00236c38 in handleTimerEvent__FP14TimerEventType
 #9   0x00231d90 in PL_HandleEvent
 #10  0x00231c78 in PL_ProcessPendingEvents
 #11  0x00232c40 in ProcessPendingEvents__16nsEventQueueImpl
 #12  0x025bdd94 in -[EventQueueHandler eventTimer:]
 #13  0x708d06e8 in __NSFireTimer
 #14  0x70196cbc in __CFRunLoopDoTimer
 #15  0x7017c244 in __CFRunLoopRun
 #16  0x701b70ec in CFRunLoopRunSpecific
 #17  0x7017b8cc in CFRunLoopRunInMode
 #18  0x7312d904 in RunEventLoopInModeUntilEventArrives
 #19  0x731407a4 in ReceiveNextEventCommon
 #20  0x731715fc in BlockUntilNextEventMatchingListInMode
 #21  0x70bd70b8 in _DPSNextEvent
 #22  0x70bfe5d8 in -[NSApplication 
nextEventMatchingMask:untilDate:inMode:dequeue:]
 #23  0x70c23468 in -[NSApplication run]
 #24  0x70c91ed0 in NSApplicationMain
 #25  0x00002978 in _start
 #26  0x000027a8 in start

Thread 1:
 #0   0x700252fc in select
 #1   0x00161758 in poll
 #2   0x0015de70 in _pr_poll_with_poll
 #3   0x01f4d684 in Run__24nsSocketTransportService
 #4   0x00234800 in Main__8nsThreadPv
 #5   0x0015f32c in _pt_root
 #6   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x0015a418 in PR_WaitCondVar
 #3   0x01f57914 in DequeuePendingQ__12nsDNSService
 #4   0x01f5731c in Run__12nsDNSService
 #5   0x00234800 in Main__8nsThreadPv
 #6   0x0015f32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x0015a1b4 in pt_TimedWait
 #4   0x0015a42c in PR_WaitCondVar
 #5   0x00238260 in Run__11TimerThread
 #6   0x00234800 in Main__8nsThreadPv
 #7   0x0015f32c in _pt_root
 #8   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x0015a418 in PR_WaitCondVar
 #3   0x00235920 in GetRequest__12nsThreadPoolP9nsIThread
 #4   0x00236274 in Run__20nsThreadPoolRunnable
 #5   0x00234800 in Main__8nsThreadPv
 #6   0x0015f32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 5:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

Thread 6:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7086c34c in -[NSConditionLock lockWhenCondition:]
 #3   0x70ba1358 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x70842358 in forkThreadForFunction
 #5   0x7002054c in _pthread_body


PPC Thread State:
  srr0: 0x7350cf04 srr1: 0x0000d030                vrsave: 0x00000000
   xer: 0x20000004   lr: 0x734ed440  ctr: 0x70000a30   mq: 0x00000000
    r0: 0x734ed440   r1: 0xbfffe6b0   r2: 0xbfffdee8   r3: 0x03e672b0
    r4: 0xffffffff   r5: 0x03df31a0   r6: 0x03de9c1c   r7: 0x00000004
    r8: 0x03df319c   r9: 0x7d9b03e7  r10: 0xff996601  r11: 0x03e672b0
   r12: 0x73501cc8  r13: 0x00000000  r14: 0x00000033  r15: 0x00f59720
   r16: 0x00f59720  r17: 0xbfffee90  r18: 0x00ac6dd8  r19: 0x00002707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x00000004  r25: 0x000006eb  r26: 0x8081ab5c  r27: 0x00f5b0b0
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x00000000  r31: 0x00000001

**********

Comment 1

16 years ago
*** Bug 149255 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
We're doing something nasty in our drawing code

->pinkerton
Assignee: saari → pinkerton
(Assignee)

Comment 3

16 years ago
already fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
Verified using 06-06 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.