Closed Bug 1492560 Opened Last year Closed 9 months ago

Datepicker popup doesn't move the month when using the < > arrows

Categories

(MailNews Core :: XUL Replacements, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jorgk, Unassigned)

Details

Using Jonathan Kamens' "Datepicker Bug Reproducer" add-on ported to legacy WE from bug 1492522, attachment 9010404 [details], type this into the error console:

openDialog("chrome://dtpr/content/dialog.xul", "_blank", "chrome,titlebar,modal,resizable", null);

Use the pulldown on the first date picker and then the < > arrows to move the month forward or backward. Result: The month name doesn't change.

Jonathan, could you please take a look. We'll try not to punish any good deed this time ;-) (not that we did last time).
Flags: needinfo?(jik)
I'm not sure what you're asking me for here. Can you clarify?

Also, I am using the daily build from March 21, which is 61.0a1, but despite the fact that I have the extensions.checkCompatibility.61.0 preference set to false, it won't let me install the referenced XPI, saying it's not compatible with my version of TB. Any ideas about that?
Flags: needinfo?(jik)
The XPI is your original add-on as a WebExtension compatible with TB 63+. Please download a TB 64 Daily and follow comment #0. It would be good if you could fix the date picker so the pull-down works again.
I will put this on my to-do list, but I do not know when I will be able to get a chance to look at it.

It's still not at all clear to me that my add-on which uses the datepicker, Send Later is even going to be compatible with TB 63+ without me doing a great deal of work that I'm not sure I'm going to have time to do -- it seems like there's much that's still up in the air about what maintainers of legacy add-ons are going to have to do to make them compatible with the next released version of TB after 63? -- and frankly, if I'm not going to be able to keep supporting Send Later in TB 63+, I don't think I can justify spending my time fixing datepicker.
I understand.

With luck, legacy XUL add-ons will "just work" with TB's home-cooked overlay loader. Of course only if they adapt to changed/changing interfaces, see https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_63#Removed_in_mozilla61 and below.

I got "Signature Switch" going (not my own add-on), so that's positive.

Well, the date/time picker binding got removed in bug 1527535 so there's nothing left to fix here.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WONTFIX

Broken since at least TB 64.

Version: 24 → 64
You need to log in before you can comment on or make changes to this bug.