Update webrender to f17f6a491d6ff3dc3e13e998dda788d8f5856338

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P3
normal
RESOLVED FIXED
8 months ago
4 months ago

People

(Reporter: darkspirit, Assigned: jrmuizel)

Tracking

(Blocks 3 bugs)

64 Branch
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

(Whiteboard: [gfx-noted], )

+++ This bug was initially created as a clone of Bug #1492389 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh

Comment 2

8 months ago
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/14c6b338e32c
Update webrender to f17f6a491d6ff3dc3e13e998dda788d8f5856338
Reporter

Updated

8 months ago
Duplicate of this bug: 1492389
Reporter

Updated

8 months ago
Alias: wr-future-update
Assignee: nobody → jmuizelaar
Summary: Future webrender update bug → Update webrender to f17f6a491d6ff3dc3e13e998dda788d8f5856338
Assignee

Comment 4

8 months ago
I didn't realize the previous update had been backed out. So I've made a mess of things...

Comment 6

8 months ago
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ec508b8d47b
Increase the fuzz some more so that things pass.
Depends on: 1493180
Depends on: 1493401
Reporter

Updated

8 months ago
Blocks: 1477449
Reporter

Updated

8 months ago
Blocks: 1472455
Reporter

Updated

8 months ago
Blocks: 1474294
Reporter

Updated

7 months ago
Blocks: 1490883
Reporter

Updated

4 months ago
Blocks: 1446685
You need to log in before you can comment on or make changes to this bug.