Crash when opening a .svg file [@ nsDebug::Assertion]

RESOLVED DUPLICATE of bug 141252

Status

()

Core
SVG
--
critical
RESOLVED DUPLICATE of bug 141252
16 years ago
13 years ago

People

(Reporter: Sebastian Bergmann, Assigned: Alex Fritze)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    20020605 (Current CVS)



Reproducible: Always
Steps to Reproduce:
1. Load http://www.sebastian-bergmann.de/stuff/Observer.svg
2.
3.

Actual Results:  Crash.


Debug Output:

Document file:///C:/home/phpoopbook/figures/Observer.svg loaded successfully
WEBSHELL+ = 4
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRa
wPtr != 0', file ..\..\dist/include/xpcom\nsCOMPtr.h, line 650
Break: at file ..\..\dist/include/xpcom\nsCOMPtr.h, line 650

Stacktrace:

NTDLL! 778a018c()
nsDebug::Assertion(const char * 0x01c5181c `string', const char * 0x01c51858
`string', const char * 0x01c51e34 `string', int 650) line 278 + 13 bytes
nsDebug::PreCondition(const char * 0x01c5181c `string', const char * 0x01c51858
`string', const char * 0x01c51e34 `string', int 650) line 433 + 21 bytes
nsCOMPtr<nsIFile>::operator->() line 650 + 34 bytes
nsExternalAppHandler::ExecuteDesiredAction() line 1409 + 18 bytes
nsExternalAppHandler::OnStopRequest(nsExternalAppHandler * const 0x036fa088,
nsIRequest * 0x036f48e0, nsISupports * 0x00000000, unsigned int 0) line 1391
nsDocumentOpenInfo::OnStopRequest(nsDocumentOpenInfo * const 0x036f4a78,
nsIRequest * 0x036f48e0, nsISupports * 0x00000000, unsigned int 0) line 256
nsFileChannel::OnStopRequest(nsFileChannel * const 0x036f48e8, nsIRequest *
0x036f4ac4, nsISupports * 0x00000000, unsigned int 0) line 519 + 41 bytes
nsOnStopRequestEvent::HandleEvent() line 213
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x03729fbc) line 116
PL_HandleEvent(PLEvent * 0x03729fbc) line 596 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x010ddfb8) line 526 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00af026c, unsigned int 49346, unsigned int 0,
long 17686456) line 1077 + 9 bytes
USER32! 77e01b60()
USER32! 77e01cca()
USER32! 77e083f1()
nsAppShellService::Run(nsAppShellService * const 0x01116150) line 451
main1(int 1, char * * 0x00307248, nsISupports * 0x00000000) line 1456 + 32 bytes
main(int 1, char * * 0x00307248) line 1805 + 37 bytes
mainCRTStartup() line 338 + 17 bytes

Updated

16 years ago
Severity: normal → critical
Keywords: crash
Summary: Crash when opening a .svg file → Crash when opening a .svg file [@ nsDebug::Assertion]

Comment 1

16 years ago
WFM 2002060408/trunk/W2K
(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 141252 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsDebug::Assertion]
You need to log in before you can comment on or make changes to this bug.