debug assertion failure: 'intersection.is_some() || self.texture_cache.needs_upload' loading large blob image

RESOLVED FIXED in Firefox 64

Status

()

defect
P2
normal
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: bholley, Assigned: nical)

Tracking

(Blocks 1 bug)

unspecified
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

STR: load https://static.mozilla.com/moco/en-US/images/mozilla_eoy_2013_EN.svg in a debug build (using a build from yesterday).

Result:

thread 'WRRenderBackend#4' panicked at 'assertion failed: intersection.is_some() ||
    self.texture_cache.needs_upload(&entry.texture_cache_handle)', gfx/webrender/src/resource_cache.rs:1463:21
stack backtrace:
   0:        0x11b792f5f - std::sys::unix::backtrace::tracing::imp::unwind_backtrace::hdfdb4ba75a1dcb88
   1:        0x11b765c5a - std::sys_common::backtrace::print::h5823bdde4d2f8639
   2:        0x11b79d043 - std::panicking::default_hook::{{closure}}::h06fc925781e26cfe
   3:        0x11b79cdcc - std::panicking::default_hook::hdfdcc6f72e7aec0a
   4:        0x11b79d737 - std::panicking::rust_panic_with_hook::h28749c6c929f49fc
Likely caused by Nical's stuff.
Flags: needinfo?(nical.bugzilla)
Assignee: nobody → nical.bugzilla
Flags: needinfo?(nical.bugzilla)
Depends on: 1493097
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.