Closed Bug 1492702 Opened Last year Closed Last year

'Send Link to Device' sends current page instead of selected link

Categories

(Firefox :: Sync, defect)

64 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: westleypoon, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180919220108

Steps to reproduce:

Right click on a link, 'Send Link to Device'


Actual results:

The current page is sent to the other device (similar to 'Send Tab to Device')


Expected results:

Expected the link to be sent - works fine on 62 and latest iOS version
I can confirm this report with a current nightly on windows10.

Regression range search was complicated because of bug 1489754 (regression from bug 1489754). 
I suspect that bug 1489754 is also the reason for this bug but will confirm that later.
Blocks: 1470555
Status: UNCONFIRMED → NEW
Component: Untriaged → Sync
Ever confirmed: true
Flags: needinfo?(jaws)
Keywords: regression
confirmed with mozregression: 
bug 1470555 gets fixed and causes bug 1489754 and after bug 1489754 got fixed you can see this bug appearing.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Comment on attachment 9012335 [details]
Bug 1492702 - Send the contextual link to the device, not the selected tab when a link is right-clicked. r?markh

Mark Hammond [:markh] - PTO until Sept 17 has approved the revision.
Attachment #9012335 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f7a1c065ecf
Send the contextual link to the device, not the selected tab when a link is right-clicked. r=markh
https://hg.mozilla.org/mozilla-central/rev/2f7a1c065ecf
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.