Closed Bug 1492761 Opened 4 years ago Closed 4 years ago

[MATE/gnome-shell] Scrollbar thumb disappears when window is not focused

Categories

(Core :: Widget: Gtk, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1489963
Tracking Status
firefox64 --- affected

People

(Reporter: stransky, Assigned: stransky)

Details

STR:
  0. Install marco 1.22 compositor with backdrop support,
     use Adwaita as fallback theme
  1. Open any scrollable page, so that a scrollbar track
     and scrollbar thumb are rendered
  2. Switch focus to another window (while keeping the
     Firefox window shown)

Expected results:
  The scrollbar thumb continues to be rendered

Actual results:
  The scrollbar thumb disappears
Assignee: nobody → stransky
This is because the theme is animated and Firefox does not support theme animations. We use a first frame of the animation which is a transparent thumb.
Keywords: regression
Summary: [MATE] Scrollbar thumb disappears when window is not focused → [MATE/gnome-shell] Scrollbar thumb disappears when window is not focused
I can confirm this with using adwaita theme in mate-session during testing https://github.com/mate-desktop/marco/issues/427
It's not related to MATE after all, closing as dupe of Bug 1489963.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.