quirks mode layout with table and form tags no longer matches NS 4

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Scott Kester, Assigned: John Keiser (jkeiser))

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FIX], URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020604
BuildID:    2002060404

In order to suppress unwanted space around a form element in NS4, it is a common
technique to embed the form tag between the <table> and <tr> tags inside a
nested table.  Quirks mode was matching the NS4 behavior until the 2002060404
build.  Mozilla now includes the space the above technique is used to suppress.

Reproducible: Always
Steps to Reproduce:
1.go to www.weather.com
2.see space between banner image and yellow bar
3.also www.usatoday.com layout is broken, I believe due to the same bug.

Actual Results:  There is a 10 or so pixel gap between the image and the yellow
bar on www.weather.com.  This is caused by the form tag in the table.

Expected Results:  There should not be a space, and was not prior to 20020604
builds.

I will attach a test case soon.
(Reporter)

Comment 1

16 years ago
Created attachment 86397 [details]
nested table form tag layout bug test case

This attachment shows the layout problem this bug is about.  Note the space
between the top image, and the black line image.
(Reporter)

Comment 2

16 years ago
Created attachment 86398 [details]
same html but without the form tags

test case without the form tags.  Note the lack of space between the images.
(Assignee)

Comment 3

16 years ago
Yep, this is a result of bug 125578, and probably important unfortunately :(  IE
mimicks the bad behavior.  I will look to see what went wrong.
Assignee: attinasi → jkeiser
Blocks: 125578
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

16 years ago
*** Bug 149339 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
*** Bug 149560 has been marked as a duplicate of this bug. ***

Updated

16 years ago
OS: Linux → All
Hardware: PC → All

Updated

16 years ago
QA Contact: petersen → moied
(Assignee)

Comment 6

16 years ago
Created attachment 86840 [details] [diff] [review]
Patch

The problem is, *before* we removed nsFormFrame the frame was being constructed
before we got to ConstructFrameByDisplayType and so that function was never
called.  Now the frame is created inside that function, and a check is done in
there to see if we need to create TR TD frames for content.  That check needs
to ignore the form tag.
(Assignee)

Updated

16 years ago
Whiteboard: [FIX]
Comment on attachment 86840 [details] [diff] [review]
Patch

r=dbaron, although karnaze should probably look at this too
Attachment #86840 - Flags: review+

Comment 8

16 years ago
Comment on attachment 86840 [details] [diff] [review]
Patch

sr=waterson. karnaze, you okay with it?
Attachment #86840 - Flags: superreview+

Comment 9

16 years ago
Bug still present in 2002060804.

Comment 10

16 years ago
Is the www.fcenter.ru top table problem the same?

If not please 

Comment 11

16 years ago
Eugene: Yes, www.fcenter.ru is messed up because of this bug.

Comment 12

16 years ago
*** Bug 150283 has been marked as a duplicate of this bug. ***
shouldn't we actually check the namespace ID too?
(Assignee)

Comment 14

16 years ago
Yes, but
(a) we don't check it anywhere else in the file, so I'd prefer we do it all at
once, and
(b) there are at least two namespace IDs that need to be checked--None and
XHTML, and this makes me wonder if there are possibly more, so I'll leave it to
whomever thinks about these things during step (a).

Comment 15

16 years ago
Forms shouldn't ever cause anonymous frames to be constructed inside tables, row 
groups, etc. and I thought we weren't doing that, so I'm a little surprised. But 
the patch looks ok to me, if you run the table regression tests.

Comment 16

16 years ago
*** Bug 150381 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 150821 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: testcase

Comment 18

16 years ago
The last dupe claims that http://money.cnn.com/ is another example. If this is
correct, this is the most visible example.

pi

Comment 19

16 years ago
Yes, this is correct. Build 2002061204 / win2000
(Assignee)

Updated

16 years ago
Blocks: 149279

Comment 20

16 years ago
*** Bug 151471 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 151464 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
*** Bug 151280 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
*** Bug 151517 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 24

16 years ago
Quick question.  Any idea when the attached patch will be checked in on this? 
This bug is generating lots of dupes, and the patch has r and sr. Does it need
drivers approval?  Is there any other reason not to check it in?

Comment 25

16 years ago
*** Bug 151655 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 26

16 years ago
Regression tests passed with only expected changes.  Will check in tonight after
I watch the new Clancy movie.

Comment 27

16 years ago
*** Bug 151664 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 28

16 years ago
Fix checked in to trunk.  That's revision 750 of nsCSSFrameConstructor.  Wow.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 29

16 years ago
Confirming - fixed in build 2002061404.
Thanks guys!

Comment 30

16 years ago
*** Bug 151835 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
*** Bug 151269 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
*** Bug 152078 has been marked as a duplicate of this bug. ***
*** Bug 152117 has been marked as a duplicate of this bug. ***

Comment 34

16 years ago
*** Bug 151979 has been marked as a duplicate of this bug. ***

Comment 35

16 years ago
*** Bug 151106 has been marked as a duplicate of this bug. ***

Comment 36

16 years ago
*** Bug 151707 has been marked as a duplicate of this bug. ***

Comment 37

16 years ago
*** Bug 153652 has been marked as a duplicate of this bug. ***

Comment 38

16 years ago
*** Bug 154605 has been marked as a duplicate of this bug. ***

Comment 39

16 years ago
*** Bug 154812 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
*** Bug 155773 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
*** Bug 156272 has been marked as a duplicate of this bug. ***

Comment 42

16 years ago
*** Bug 157462 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
*** Bug 152892 has been marked as a duplicate of this bug. ***

Comment 44

16 years ago
Maybe not 100% fixed... Missing quirk support for table height attribute.
Example URL:

http://www.breezeway.tv

Completely different rendering of the table in NS4/IE. Unfortuanly, I know of no
other way in HTML or even CSS to set a relative vertical alignment, as in the
example URL, except by using the "deprecated" (yet no replament is recommended...)
table HEIGHT and VALIGN attribs. Anyway, quirk mode support should be there.

Comment 45

15 years ago
V fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.