Firefox breaks after removing/undoing a deleted language pack in the same session

RESOLVED WONTFIX

Status

()

defect
--
major
RESOLVED WONTFIX
7 months ago
7 months ago

People

(Reporter: emilghitta, Unassigned)

Tracking

({regressionwindow-wanted})

Trunk
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 affected, firefox63 affected, firefox64 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
Posted image LanguagePack.gif
[Affected versions]:
Firefox 64.0a1 (BuildId:20180919220108)
Firefox 63.0b7 (BuildId:20180917143811)
Firefox 62.0 (BuildId:20180830143136)

[Unaffected versions]:
Firefox 60.2.0esr (BuildId:20180903060751)

[Affected platforms]:
Windows 10 64bit.
Windows 10 32bit.
Ubuntu 16.04 64bit.
macOS 10.13.6

[Preconditions]
1. Launch Firefox.
2. Install a language pack xpi.
3. Create the intl.locale.requested pref and have it set with what locale you have installed.
4. Restart Firefox.

[Steps to reproduce]:
1. Access the profile path and delete the xpi from the extensions folder (While Firefox is open). DON'T restart Firefox.
2. Access the about:addons page.
3. Remove the language pack (via the Remove button).
4. Click the "Undo" button.
5. Access any about page.

[Expected result]:
The about pages are displayed successfully.

[Actual result]:
The about pages become unusable.

[Regression Range]:
I will get back with a regression range asap.

[Additional Notes]
- For further information regarding this issue please observe the attached screencast.
(Reporter)

Comment 1

7 months ago
Posted image Close Firefox.gif
I have encountered another scenario, which seems to be worse. 
On some locales (ex ff), while this issue is encountered, Firefox is not closeable.
I managed to reproduce this scenario by disabling/enabling the xpi from about:addons (instead of remove/undo from steps 3 and 4) and then pressing the X button or trying to quit Firefox via the Hamburger menu.
Closing this as that's a pretty edgy edge case (the remove and undo remove part).
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.