JavaScript can't execute Flash functions

VERIFIED DUPLICATE of bug 110441

Status

Tech Evangelism Graveyard
Other
--
major
VERIFIED DUPLICATE of bug 110441
16 years ago
3 years ago

People

(Reporter: Claudio Palludetti, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.0rc3) Gecko/20020524
BuildID:    2002052410

In this page there is a Flash which you can interact with it selecting some link
(for example: call(moon)), but nothing happens. In the JavaScript Console you get:

Error: document.ufo.TCallLabel is not a function
Source File: javascript:document.ufo.TCallLabel('/', 'moon');
Line: 1

With netscape 4.61 work fine, But with mozilla, netscape 6.x and 7 don't.

Reproducible: Always
Steps to Reproduce:
1.Go to the URL
2.Search "Controlling Flash Movies"
3.Click on any link below the flash 


Actual Results:  If you press on link call(moon) nothing happens

Expected Results:  The moon must hide or show

Comment 1

16 years ago
Browser, not engine ---> Plug-ins. 

Claudio: what version of Flash are you using?
(In Mozilla, do Help > About Plug-ins to see this)
Assignee: rogerl → beppe
Component: JavaScript Engine → Plug-ins
QA Contact: pschwartau → shrir

Comment 2

16 years ago
flash scriptability issue? invalid?
(Reporter)

Comment 3

16 years ago
------------------------------------------------------------------------
Shockwave Flash

   File name: D:\mozilla\bin\plugins\npswf32.dll
Shockwave Flash 6.0 r23 

Comment 4

16 years ago
Claudio: thanks - 

Here is the "ufo" element from the page in question:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"         
        CODEBASE="http://download.macromedia.com/pub/shockwave/
                  cabs/flash/swflash.cab#version=4,0,2,0" 
        WIDTH="400" HEIGHT="200" NAME="ufo" ID="ufo">

  <PARAM NAME=movie VALUE="flash/ufo.swf">
  <PARAM NAME=quality VALUE=high>

  <EMBED SRC="flash/ufo.swf" QUALITY=high          
         PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?
                      P1_Prod_Version=ShockwaveFlash"
         TYPE="application/x-shockwave-flash"
         WIDTH="400" HEIGHT="200" NAME="ufo" SWLIVECONNECT="true">
  </EMBED> 
</OBJECT>


This explains the problem, right? |SWLIVECONNECT="true"|
That means the site is trying to use LiveConnect scripting,
when they should be using XPConnect scripting for the plug-in - ? 

So this bug should be sent to Evangelism, then; is that right?

Comment 5

16 years ago
not sure..maybe invalid...or wontfix. I am not sure.

Comment 6

16 years ago
-->evang

Flash isn't scriptable yet.
Assignee: beppe → nitot
Status: UNCONFIRMED → NEW
Component: Plug-ins → African
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: shrir → momoi
Version: other → unspecified

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 110441 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
english non us for now
Component: African → English: Non-US
tech evang june 2003 reorg
Assignee: nitot → other
Component: English: Non-US → Other
QA Contact: momoi → other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.