<table border=1> with css: table { border-collapse}; td,tr { border-width: 0px; } are rendered with glitches

RESOLVED DUPLICATE of bug 128930

Status

()

Core
Layout: Tables
P2
major
RESOLVED DUPLICATE of bug 128930
16 years ago
15 years ago

People

(Reporter: Vlad Harchev, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
Future
All
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Scroll this page back and forth (vertically) using up/down keys
(don't use PGUP/PGDOWN keys - only cursor up/cursor down!) and
look at the table below.

What's wrong with it (at least in 0.9.9):

    The table carcass is rendered as a black grid. That's wrong - since
the border width is set to 0px for cells and rows. 0.9.6 and IE of any
version don't show a grid at all - just a border AROUND the table.

    When you scroll the table, there appear black horizontal lines that
are continuation of the rows separators (they have the width of the
window!). That's a bug in rendering code!

Both problems are absent in 0.9.6 (and IE, any version).
When one removes border=1 from <table border=1>, both problems disappear
in 0.9.9 too (but these problems shouldn't be there anyway).
Not a DOM problem, over to HTMLTables for further investigation...
Assignee: jst → karnaze
Component: DOM Style → HTMLTables
QA Contact: ian → amar

Comment 2

16 years ago
This is an issue of table border-collapse: collapse. Marking P2 since this can
be an regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

Updated

15 years ago
Target Milestone: --- → Future

Comment 3

15 years ago
Reproduced on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-CA; rv:1.0.2)
Gecko/20021120 Netscape/7.01, Win 2K. Testcase Keyword added.
Keywords: testcase

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 128930 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.