Closed Bug 1493092 Opened 3 years ago Closed 2 years ago

Intermittent /webdriver/tests/get_element_rect/user_prompts.py | test_default[alert-None] - UnknownErrorException: unknown error (500): Failed to decode response from marionette

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1488790

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure)

Filed by: aiakab [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=200672513&repo=autoland

https://queue.taskcluster.net/v1/task/e0cO1_A_RbyIDqTFis7ujw/runs/0/artifacts/public/logs/live_backing.log

23:56:05     INFO - TEST-PASS | /webdriver/tests/get_element_rect/user_prompts.py | test_dismiss_and_notify[capabilities0-prompt-None] 
23:56:05     INFO - TEST-PASS | /webdriver/tests/get_element_rect/user_prompts.py | test_ignore[capabilities0-alert] 
23:56:05     INFO - TEST-PASS | /webdriver/tests/get_element_rect/user_prompts.py | test_ignore[capabilities0-confirm] 
23:56:05     INFO - TEST-PASS | /webdriver/tests/get_element_rect/user_prompts.py | test_ignore[capabilities0-prompt] 
23:56:05     INFO - TEST-UNEXPECTED-FAIL | /webdriver/tests/get_element_rect/user_prompts.py | test_default[alert-None] - UnknownErrorException: unknown error (500): Failed to decode response from marionette
23:56:05     INFO - check_user_prompt_closed_with_exception = <function check_user_prompt_closed_with_exception at 0x10a69c6e0>
23:56:05     INFO - dialog_type = 'alert', retval = None
23:56:05     INFO - 
23:56:05     INFO -     @pytest.mark.parametrize("dialog_type, retval", [
23:56:05     INFO -         ("alert", None),
23:56:05     INFO -         ("confirm", False),
23:56:05     INFO -         ("prompt", None),
23:56:05     INFO -     ])
23:56:05     INFO -     def test_default(check_user_prompt_closed_with_exception, dialog_type, retval):
23:56:05     INFO - >       check_user_prompt_closed_with_exception(dialog_type, retval)
23:56:05     INFO - 
23:56:05     INFO - check_user_prompt_closed_with_exception = <function check_user_prompt_closed_with_exception at 0x10a69c6e0>
23:56:05     INFO - dialog_type = 'alert'
23:56:05     INFO - retval     = None
23:56:05     INFO - 
23:56:05     INFO - tests/web-platform/tests/webdriver/tests/get_element_rect/user_prompts.py:122: 
23:56:05     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
23:56:05     INFO - tests/web-platform/tests/webdriver/tests/get_element_rect/user_prompts.py:40: in check_user_prompt_closed_with_exception
23:56:05     INFO -     session.url = inline("<input>")
23:56:05     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:20: in inner
23:56:05     INFO -     return func(self, *args, **kwargs)
23:56:05     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:522: in url
23:56:05     INFO -     return self.send_session_command("POST", "url", body)
23:56:05     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:509: in send_session_command
23:56:05     INFO -     return self.send_command(method, url, body)
23:56:05     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
23:56:05     INFO - 
23:56:05     INFO - self = <Session 4c774059-ab0a-1142-8b77-f1ff258352b6>, method = 'POST'
23:56:05     INFO - url = 'session/4c774059-ab0a-1142-8b77-f1ff258352b6/url'
23:56:05     INFO - body = {'url': 'http://web-platform.test:8000/webdriver/tests/support/inline.py?doc=%3Cinput%3E&content-type=text%2Fhtml%3Bcharset%3Dutf-8'}
23:56:05     INFO - 
23:56:05     INFO -     def send_command(self, method, url, body=None):
23:56:05     INFO -         """
23:56:05     INFO -             Send a command to the remote end and validate its success.
23:56:05     INFO -     
23:56:05     INFO -             :param method: HTTP method to use in request.
23:56:05     INFO -             :param uri: "Command part" of the HTTP request URL,
23:56:05     INFO -                 e.g. `window/rect`.
23:56:05     INFO -             :param body: Optional body of the HTTP request.
23:56:05     INFO -     
23:56:05     INFO -             :return: `None` if the HTTP response body was empty, otherwise
23:56:05     INFO -                 the `value` field returned after parsing the response
23:56:05     INFO -                 body as JSON.
23:56:05     INFO -     
23:56:05     INFO -             :raises error.WebDriverException: If the remote end returns
23:56:05     INFO -                 an error.
23:56:05     INFO -             :raises ValueError: If the response body does not contain a
23:56:05     INFO -                 `value` key.
23:56:05     INFO -             """
23:56:05     INFO -         response = self.transport.send(
23:56:05     INFO -             method, url, body,
23:56:05     INFO -             encoder=protocol.Encoder, decoder=protocol.Decoder,
23:56:05     INFO -             session=self)
23:56:05     INFO -     
23:56:05     INFO -         if response.status != 200:
23:56:05     INFO -             err = error.from_response(response)
23:56:05     INFO -     
23:56:05     INFO -             if isinstance(err, error.InvalidSessionIdException):
23:56:05     INFO -                 # The driver could have already been deleted the session.
23:56:05     INFO -                 self.session_id = None
23:56:05     INFO -     
23:56:05     INFO - >           raise err
23:56:05     INFO - E           UnknownErrorException: unknown error (500): Failed to decode response from marionette
23:56:05     INFO - 
23:56:05     INFO - body       = {'url': 'http://web-platform.test:8000/webdriver/tests/support/inline.py?doc=%3Cinput%3E&content-type=text%2Fhtml%3Bcharset%3Dutf-8'}
23:56:05     INFO - err        = <UnknownErrorException http_status=500>
23:56:05     INFO - method     = 'POST'
23:56:05     INFO - response   = <Response status=500 error=<UnknownErrorException http_status=500>>
23:56:05     INFO - self       = <Session 4c774059-ab0a-1142-8b77-f1ff258352b6>
23:56:05     INFO - url        = 'session/4c774059-ab0a-1142-8b77-f1ff258352b6/url'
23:56:05     INFO - 
23:56:05     INFO - tests/web-platform/tests/tools/webdriver/webdriver/client.py:473: UnknownErrorException
23:56:05     INFO - ..
23:56:05     INFO - TEST-OK | /webdriver/tests/get_element_rect/user_prompts.py | took 29450ms
23:56:15  WARNING - Forcibly terminating runner process
23:56:16     INFO - Starting runner
23:56:16     INFO - PID 855 | 1537512976035	webdriver::httpapi	DEBUG	Creating routes
23:56:16     INFO - PID 855 | 1537512976043	geckodriver	DEBUG	Listening on 127.0.0.1:4444
23:56:16     INFO - WebDriver HTTP server listening at http://127.0.0.1:4444/
Firefox crashed during navigation:

> 23:56:00     INFO - PID 817 | 1537512960142	Marionette	TRACE	0 -> [0,3,"WebDriver:Navigate",{"url":"http://web-platform.test:8000/webdriver/tests/support/inline.py?doc=%3Cinput%3E&content-type=text%2Fhtml%3Bcharset%3Dutf-8"}]
> 23:56:00     INFO - PID 817 | 1537512960180	Marionette	DEBUG	[4294967297] Received DOM event beforeunload for about:blank
> 23:56:00     INFO - PID 817 | 1537512960205	Marionette	DEBUG	[4294967297] Received DOM event pagehide for about:blank
> 23:56:00     INFO - PID 817 | 1537512960227	Marionette	DEBUG	[4294967297] Received DOM event DOMContentLoaded for http://web-platform.test:8000/webdriver/tests/support/inline.py?doc=%3Cinput%3E&content-type=text%2Fhtml%3Bcharset%3Dutf-8
> 23:56:00     INFO - PID 817 | ** Unknown exception behavior: -2147483647
> 23:56:00     INFO - PID 817 | 1537512960258	webdriver::server	DEBUG	Deleting session

For crash details we would need bug 1490906 fixed first.
Depends on: 1490906
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 1488790
You need to log in before you can comment on or make changes to this bug.