Closed Bug 1493149 Opened Last year Closed Last year

/moz/addon/install command regression: "data did not match any variant of untagged enum Helper"

Categories

(Testing :: geckodriver, defect, P2)

64 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 fixed, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: barancev, Assigned: whimboo)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

Geckodriver: 0.22
Platform: Windows
Firefox: Nightly 64.0a1 (2018-09-20) (64-bit)
Selenium: HEAD, Java binding

Sample code:

driver.installExtension(Paths.get("c:\\Temp\\search_encrypt-2.8.3-an+fx.xpi"));

0.22 trace log:

1537532269894	webdriver::server	DEBUG	-> POST /session/ff9a2565-6cd5-4442-b86d-0bdc3c0ac9dd/moz/addon/install {
  "path": "c:\\Temp\\search_encrypt-2.8.3-an+fx.xpi"
}
1537532269895	webdriver::server	DEBUG	<- 400 Bad Request {"value":{"error":"invalid argument","message":"data did not match any variant of untagged enum Helper","stacktrace":""}}

0.21 trace log:

1537527046406	webdriver::server	DEBUG	-> POST /session/3f70bc2e-cde0-4326-bee8-310df0708a95/moz/addon/install {
  "path": "c:\\Temp\\search_encrypt-2.8.3-an+fx.xpi"
}
1537527047014	Marionette	TRACE	0 -> [0,2,"Addon:Install",{"path":"c:\\Temp\\search_encrypt-2.8.3-an+fx.xpi","temporary":false}]
1537527052973	Marionette	TRACE	0 <- [1,2,null,{"value":"@searchencrypt"}]
1537527052974	webdriver::server	DEBUG	<- 200 OK {"value":"@searchencrypt"}
The problem is that I assumed the `temporary` flag is required, while it is optional. As such missing the key will cause this failure.

I will have a look at this early next week.
Blocks: 1396821, 1491288
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P3
Assignee: nobody → hskupin
Priority: P3 → P2
Status: NEW → ASSIGNED
With the Serde refactoring we have made this flag mandatory. This patch
reverts that change, and allows it to be skipped.
Comment on attachment 9012504 [details]
Bug 1493149 - [geckodriver] "temporary" flag in AddonInstallParameters has to be optional. r?ato

Andreas Tolfsen ❲:ato❳ has approved the revision.
Attachment #9012504 - Flags: review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6155b2f3b9c1
[geckodriver] "temporary" flag in AddonInstallParameters has to be optional. r=ato
https://hg.mozilla.org/mozilla-central/rev/6155b2f3b9c1
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Please uplift the test-only patch to beta to fix a regression with geckodriver.
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.