gopher: Page doesn't load in Mozilla, but does in IE

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Andre-John Mas, Assigned: bbaetz)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

Type the page into the address field and then hit enter. A page appears with the
URL and the progress indicator full, with text 'sending request to
gopher.umsl.edu...'. The same page appears instantaneously in IE.

Reproducible: Always
Steps to Reproduce:
1. Type in URL: gopher://gopher.umsl.edu/
2. Hit enter
3. wait
4. Do the same in IE and compare

Actual Results:  A page appears with the URL and the progress indicator full,
with text 'sending request to gopher.umsl.edu...'. The same page appears
instantaneously in IE.

Expected Results:  The page should have appeared with a gopher menu

Comment 1

16 years ago
WFM. win98, RC3 - 2002052306
*** Bug 149338 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: benc → gopherqa
Summary: Page doesn't load in Mozilla, but does in IE → gopher: Page doesn't load in Mozilla, but does in IE

Comment 3

16 years ago
Another gopher 'page':
gopher://gopher.well.sf.ca.us/00/cyberpunk/cultjam.txt

This page displays, but never stops loading (the text never changes from
'Sending request to gopher.well.sf.ca.us'). Works in IE 6.0.2600.0000 and
WSGopher32 2.0.

Comment 4

16 years ago
Hmm. Sometimes the page just comes up blank when I open a new window, paste in
the URL and try again. Alyways works in IE and WSGopher32.

I should mention that I am using Mozilla 1.0 (2002053012) on Windows 2000. Sorry
about the two emails in a row.

Comment 5

16 years ago
WFM 1.1 alpha, Windows 98. Reporter, can you reproduce this with a new profile?

Updated

16 years ago
Target Milestone: --- → Future
(Reporter)

Comment 6

16 years ago
Downloaded 1.2a, created a new Mozilla profile, on Win2K. Problem still
persists. "Stop" button won't stop the throbber, but I can type in a 
"http://" url and the next page will load.

I have also tested this under MacOS X 10.2 with Mozilla 1.2a and the
page loads without any problems. This almost appeaprs to be a Win2K
specific issue. Can anyone else confirm this? Maybe the gopher code
has incompatibilities with the Win2K network implementation?

Comment 7

16 years ago
-> bradley, when you get the time that is :-)
Assignee: new-network-bugs → bbaetz
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: gopherqa → tever
(Assignee)

Comment 8

16 years ago
Someone filed (in the last week or so) a bug against gopher not working and
included a 'patch'. The patch is wrong, but it points to what broke this.

Don't have hte bug # off hand, but there aren't that many gopher bugs. :)
Whiteboard: DUPEME

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 177060 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
VERIFIED/dupe
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
fixed URL, reopen,

wfm, mozilla 1.2.1

The problem in #3 is actually the a dupe of bug 177060, but the original bug is not.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 12

16 years ago
What I see now is that the load completes, but the tranfer status never updates
from "transfering". This happens if you click the link -or- open as new window.

This does not happen, for some reason, if you open as new tab in  the background.
Whiteboard: DUPEME

Comment 13

16 years ago
Same problem with Mozilla 1.2 for BeOS.
Please change OS to All.

Oddly enough, the root page of Gopher sites sometimes (very rarely) does open,
but the internal links never do.
This behavior is shared with Mozilla 1.2.1 and Phoenix 0.4 on Windows.

A work-around that I mentioned in Bug 184180 is to use a Proxy server:
File>>Prefs>>Advanced>>Proxies>>Gopher Proxy: host005.answer.co.jp Port:80

Prog.

Comment 14

16 years ago
PC/All.
OS: Windows 2000 → All

Updated

16 years ago
QA Contact: tever → gopherqa
(Reporter)

Comment 15

15 years ago
Revisting the links with Mozilla 1.4rc1 these pages now load fine. I recommend
QAing this issue and closing it.

Comment 16

15 years ago
RESOLVED/WFM:

Mach-O, Win98, Linux.

ajmas: can you verify?
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WONTFIX

Comment 17

15 years ago
Will switch to resolved wfm.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 18

15 years ago
Resolving as WFM.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

15 years ago
Just to confirm I have tested this with MacOS X and Windows 2000 SP2 and it
works. I am not in a position to verify Linux or Windows 98.

Comment 20

15 years ago
I can confirm it works on Windows 98.
You need to log in before you can comment on or make changes to this bug.