Closed Bug 1493255 Opened 1 year ago Closed 1 year ago

Update rules to serve Widevine 4.10.1146.0 to Firefox 64 Desktop (Windows, Mac, and Linux)

Categories

(Release Engineering :: Release Requests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bryce, Assigned: aki)

References

Details

The media team are planning to update the Widevine CDM served to Firefox 64 to version 4.10.1146.0. I have been testing locally without issue, but we still have to land some code to central before this can be rolled out for wider testing.

In order to get our ducks in a row, would it be possible to prepare rules to serve the new cdm to nightlytest? Once the code landing is done, we can move to nightlytest, and then follow that with a nightly roll out.

The following are the updated details for the CDM:

Linux 32bit:
URL https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-ia32.zip
SHA512: b2ddb423692ac0577b3179e913ae3d19baa6d5cc797b1abae6d20bbbebd4e9bd480f980026857dde87ec7ec7ad8a453454c77611b35e4108ef8e3221f85c41c7
file size: 3199840 bytes

Linux 64bit:
URL https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-x64.zip
SHA512: 056868f97bfa0235fba151556084b947340d22149ce838932aa2b700e5c76bc8b7a90d5926a1919fcf7f395193c8b80eacaa28fe6258a71f35b7b45d3d9e58ba
file size: 3057741 bytes

MacOS:
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-mac-x64.zip
SHA512: ddd4b3b0f43e50ca6edbdb9f559a0810decd96fc2982f42169c15047bfaf9e6bc722ba1601a66517a7a81d9ec1401b949376e7152bad9f85568a65bc6ace60d7
file size: 3331068 bytes

Win 7/8/10 32bit:
URL https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-ia32.zip
SHA512: 28cad1cb63878a37ce88a93595063f5e2621495ffb1a2b9816731f9470f2887dbd3ffe923806f46dd0fe9c4f654f2048238b12f617a29c26beb2793e2976c89f
file size: 3554840 bytes

Win 7/8/10 64bit:
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-x64.zip
SHA512: 440a680b21e851c5d32244808036391bbe23aa5ce5e7337f805e33877df000040d3c7b62ca6259623785d73855560592782bf2c3a3cb1ce47bdcda635d9ceed1
file size: 3523651 bytes

Last time for reference: Bug 1475260.

I have notified the release drivers mailing list of our intent to update. Please let me know if any other information is required to prepare the nightlytest rules.
The nightlytest channel should now be serving Widevine 4.10.1146.0.
Thanks! I've manually tested all of the above CDMs and everything looks good. Could We please schedule serving the new CDM to Firefox 64 from Monday the first of October (or early that week)? I'm relatively confident, but it can't hurt to have another day of testing -- as well as not tempting fate by bumping before the weekend.
Does that mean the appropriate code changes, if any, have landed in Nightly? If so, yes, we should be able to enable early next week.
Confirming that all code changes needed to accommodate the CDM in nightly have been landed and verified by myself using official nightly builds from the 27th.
I've changed the Balrog rule to roll out 4.10.1146.0 to Firefox >=64.0, starting at 11am PDT. This is pending signoff.
The new Widevine should be live for everyone on Nightly. Could you verify?
Flags: needinfo?(bvandyk)
Blocks: 1495514
Just tested with a local build from today's central and a Nightly. Both report version 64.0a1, however, I appear to still be getting CDM version 1.4.9.1088.
Flags: needinfo?(bvandyk) → needinfo?(aki)
Looks like I should have done <64.0a1 instead of <64.0 for the watershed. Fixed, pending signoff.
Signed off. I think I just got 4.10.1146.0 in my osx nightly...
Flags: needinfo?(aki)
Thank you for taking another look. Confirming I'm seeing 4.10.1146.0 on Windows 10 also.
Cool. I think we're done here?
Assignee: nobody → aki
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Sounds good. Unless testing shows up any issues with the new CDM, we should be sorted for the immediate future. Appreciate the help.
Can we revise the rules to only ship the new CDM to builds built on or later than 2018-09-31? This will avoid users on older nightly releases having issues with the new CDM.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
:jlorenzo updated the rule, 64.0a1 builds from September are back on Widevine-1.4.9.1088.
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1496408
Depends on: 1496501
See Also: → 1503124
We're seeing issues with the Widevine download for 64 and 65 failing. Starting with a fresh profile in either then loading up a page that attempts to install the CDM (Netflix, Shaka player demo) results in the following being logged to the browser console:

GMPInstallManager.simpleCheckAndInstall Could not check for addons: {"status":"failed","results":[{"id":"gmp-gmpopenh264","result":"succeeded"},{"id":"gmp-widevinecdm","result":"failed"}]}

The links in comment #0 appear to still work, could we verify the rules to make sure they're correct to serve 4.10.1146.0 to >= 64?
Status: RESOLVED → REOPENED
Flags: needinfo?(aki)
Resolution: FIXED → ---
Looks like we may have had the files change underneath us, rechecking them I see the following (note the different 512 hashes):

Attempting to hash cdm from https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-ia32.zip
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-ia32.zip
SHA256: b8bc5c3cb041fb80bae39853dfb522adf4c00cf25b4ac77d45ca791cee55dc41
SHA512: d8f440eca56b6a77bda8c10e84c840c9abe76be874fad97464456612845595518656a48a386c4ba647f9fd7a8011ce50720c8c0cd6d540e6cf16dccde7595abd
file size: 3199840 bytes

Attempting to hash cdm from https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-x64.zip
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-linux-x64.zip
SHA256: 7d0f0cb6d6bc119f41061a51eb7e570df7946b2bba5bd78bcd0d1a203192cf29
SHA512: 3ead88fe1ee8aa265176ad05552da7b3b97a900bd0d3c0d0255be5a6c59a2b8147f235d9c72bc30c8c21b3c90df4514ef8d9b6d940cbdba486a63a45724c6557
file size: 3057741 bytes

Attempting to hash cdm from https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-mac-x64.zip
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-mac-x64.zip
SHA256: 4e4f5d1b2923ef3c42a921032c387f61bdf9dfe6b62c5cd8effc79e4b41f26d7
SHA512: 3b318f39808c7f8e2cc23e79cbfa164d189a100241d3f706a094cd4a3b534026948add3ecc54e06a64b6db7439f44a65cfae275ed0006f0cee2aef2224a6e4a0
file size: 3331068 bytes

Attempting to hash cdm from https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-ia32.zip
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-ia32.zip
SHA256: 7e8db6c2e3e62999814d198745067e04e7c61c1580d75cf73534712540df5d9e
SHA512: d00fb1ce1b7d359ac0f06480d83960fc9aae25f6933e736483c7e27f86ad70a2ca7bfe45027874d1b619d3b72944372d5a7fb124ade4978efdcaeff0cc6c415b
file size: 3554840 bytes

Attempting to hash cdm from https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-x64.zip
Got https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1146.0-win-x64.zip
SHA256: cbe227e42735c0869a6369f5054b03dd8c9c3c28ffbe89fde4b8d11e141ebc6b
SHA512: 6879b1a718f121eaca93864fa08dc29d5cd5adbdcfc3c3b7dd8cabea768ef4b2cc44b0d43bd04ce2768bea8039faf0a2ebc6d81247101abbe28efda253c89197
file size: 3523651 bytes
Per comment 17, I have a scheduled change for the hashes here:
https://aus4-admin.mozilla.org/releases/scheduled_changes

I'd like another pair of releng eyes here, then we need relman signoff.
Flags: needinfo?(aki)
(In reply to Aki Sasaki [:aki] from comment #18)
> Per comment 17, I have a scheduled change for the hashes here:
> https://aus4-admin.mozilla.org/releases/scheduled_changes
> 
> I'd like another pair of releng eyes here, then we need relman signoff.

Looks good to me. You already signed off in Balrog so nothing from me for releng. I'm confused as to how the filesize is unchanged given we have different hashes but from what is in comment 17, balrog matches that.
Thanks for the rule updates. I am seeing this resolved in my current testing. The issue appears to be caused by altered modification dates for the contents of the zips. I have not seen any indication that this is something we should expect, and think it may have been an oversight. I have reached out to make sure we can rely on these new hashes to remain stable.
After speaking with Widevine this week it sounds like the new files are going to stick, so I'm going to resolve this. For posterity: the fallback downloader was not updated with the new hashes while we figured out if the files would be reverted or not. Since we're about to move to 4.10.1196.0 we'll likely just bump the fallback downloader all the way up to that with our next change.
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
No longer depends on: 1496501
You need to log in before you can comment on or make changes to this bug.