Talos profiling does not symbolicate addresses from the XUL library on macOS

RESOLVED FIXED in Firefox 64

Status

defect
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

(Blocks 1 bug, {regression})

Trunk
mozilla64
All
macOS
Points:
---

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Comment 1

7 months ago
I believe this was broken by bug 1358818. I don't think bug 1358818 achieved what it set out to do and it should be backed out.

More specifically: Symbolication gets its symbols from three sources:
 (1) The crashreporter-symbols directory or zip file that was generated for the profiled build.
 (2) Fallback to the official Mozilla symbol server.
 (3) On Linux and macOS, fallback to local symbolication by running nm or dump_syms_mac.

If the crashreporter symbols path is a URL to a zip file, then (1) will make a connection to the server that hosts this zip file.
(2) makes a connection to the Mozilla symbol server.
(3) does not make a connection and just happens locally.

I believe bug 1358818 was filed about (2), but the patch in it ended up disabling (1).

Try push with backout to confirm: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a307933e749dba1308b273526f0e718f4b05f382
Blocks: 1358818
Keywords: regression
(Assignee)

Comment 2

7 months ago
I'm always happy to review patches that have to do with symbolication.
(Assignee)

Comment 3

7 months ago
(In reply to Markus Stange [:mstange] from comment #1)
> I believe this was broken by bug 1358818. I don't think bug 1358818 achieved
> what it set out to do and it should be backed out.
> 
> Try push with backout to confirm:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=a307933e749dba1308b273526f0e718f4b05f382

That fixes it. Example profile: https://perf-html.io/from-url/https%3A%2F%2Fqueue.taskcluster.net%2Fv1%2Ftask%2FL84pxPGzSgiIh33e0GNSdg%2Fruns%2F0%2Fartifacts%2Fpublic%2Ftest_info%2Fprofile_tp5o.zip/calltree/?file=profile_tp5o%2F163.com_pagecycle_1%2Fcycle_0.profile&globalTrackOrder=0-1-2-3&hiddenGlobalTracks=1-2&localTrackOrderByPid=1750-1-0~1751-0~&thread=4&v=3
Comment on attachment 9011239 [details]
Bug 1493261 - Back out Bug 1493261 because it broke symbolication on non-Windows platforms. r?jmaher

Joel Maher ( :jmaher ) (UTC-4) has approved the revision.
Attachment #9011239 - Flags: review+

Comment 6

7 months ago
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/da42d772b73c
Back out Bug 1493261 because it broke symbolication on non-Windows platforms. r=jmaher

Comment 7

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/da42d772b73c
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Is this worth backporting to Beta?
Flags: needinfo?(mstange)
(Assignee)

Comment 9

7 months ago
Probably not. Talos performance investigations usually happen on Nightly. This change only impacts developers, it has no effects on Firefox.
Flags: needinfo?(mstange)
You need to log in before you can comment on or make changes to this bug.