Closed Bug 1493313 Opened 11 months ago Closed 11 months ago

Port bug 1491394: new mozILocaleService API - TEST-UNEXPECTED-FAIL | test-menubar-collapsed.js::test_main_menu_collapsed

Categories

(Thunderbird :: General, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 64.0

People

(Reporter: aceman, Assigned: jorgk)

References

Details

Attachments

(3 files, 2 obsolete files)

TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/startup-firstrun/test-menubar-collapsed.js | test-menubar-collapsed.js::test_main_menu_collapsed

And many other failures, mostly in Calendar.

There are new errors seen in the log:
JavaScript error: jar:file:///builds/worker/workspace/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/components/calItemModule.js -> resource://calendar/calendar-js/calStartupService.js, line 65: TypeError: Services.locale.getPackagedLocales is not a function

At TB startup, the same error at a different place:
TypeError: Services.locale.getPackagedLocales is not a function, mailGlue.js:159:19

Probably something needs to be ported from m-c.
We need to port: https://hg.mozilla.org/mozilla-central/rev/54dba2807ef8
Summary: TEST-UNEXPECTED-FAIL | test-menubar-collapsed.js::test_main_menu_collapsed → Port bug 1491394: new mozILocaleService API - TEST-UNEXPECTED-FAIL | test-menubar-collapsed.js::test_main_menu_collapsed
Attached patch 1493313-xxxLocales.patch (obsolete) — Splinter Review
This should it it. All done with sed.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #9011150 - Flags: review?(acelists)
Duplicate of this bug: 1493314
Damn, there is also: RequestedLocale, singular.
Attachment #9011150 - Attachment is obsolete: true
Attachment #9011150 - Flags: review?(acelists)
Attachment #9011152 - Flags: review?(acelists)
Comment on attachment 9011152 [details] [diff] [review]
1493313-xxxLocales.patch (v2)

Review of attachment 9011152 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, fixes the errors and makes Lightning work for me locally.
Attachment #9011152 - Flags: review?(acelists) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a01d1481ef18
Port bug 1491394: Replace {get|set}XxxLocales() with xxxLocales. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Attachment #9011152 - Flags: review?(makemyday)
Missed appLocalesAsBCP47. Fails one calendar test and breaks Advanced pane in Options.

Try run: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=4cb0eeb7614036d5e8e6e75df20689e63177714a
Attachment #9011165 - Flags: review?(jorgk)
Comment on attachment 9011165 [details] [diff] [review]
appLocalesAsBCP47

Yes, I missed it, since it wasn't advertised :-(
https://groups.google.com/d/msg/mozilla.dev.platform/csDd-PFftLg/hOXKXpm4CgAJ
Attachment #9011165 - Flags: review?(jorgk) → review+
Attachment #9011165 - Flags: review?(makemyday)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ed984c4258e9
Port Bug 1491394: Replace getAppLocalesAsBCP47() with appLocalesAsBCP47. r=jorgk DONTBUILD
Component: Testing Infrastructure → General
Comment on attachment 9011165 [details] [diff] [review]
appLocalesAsBCP47

Review of attachment 9011165 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #9011165 - Flags: review?(makemyday) → review+
Comment on attachment 9011152 [details] [diff] [review]
1493313-xxxLocales.patch (v2)

Review of attachment 9011152 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, r+wc

::: calendar/providers/gdata/modules/gdataSession.jsm
@@ +137,5 @@
>          this.oauth = new OAuth2(OAUTH_BASE_URI, OAUTH_SCOPE, OAUTH_CLIENT_ID, OAUTH_CLIENT_SECRET);
>          this.oauth.extraAuthParams = [
>            ["login_hint", sessionId],
>            // Use application locale for login dialog
> +          ["hl", Services.locale.requestedLocale]

Please make this backward compatible, since Gdata is build cross version from c-c.

(typeof Services.locale.requestedLocale === "undefined") ? Services.locale.getRequestedLocale() : Services.locale.requestedLocale
Attachment #9011152 - Flags: review?(makemyday) → review+
Attached patch 1493313-follow-up-gdata.patch (obsolete) — Splinter Review
Like so? I linted it. I think we can lose the parenthesis, no?
Attachment #9011189 - Flags: review?(makemyday)
Without parenthesis, like here:
https://searchfox.org/comm-central/rev/4f2ab5a24b507f5bbf7c6ad012d44128fa017ef5/calendar/base/modules/utils/calItipUtils.jsm#1139
Attachment #9011189 - Attachment is obsolete: true
Attachment #9011189 - Flags: review?(makemyday)
Attachment #9011190 - Flags: review?(makemyday)
Comment on attachment 9011190 [details] [diff] [review]
1493313-follow-up-gdata.patch

Review of attachment 9011190 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, looks good. We use both patterns.
Attachment #9011190 - Flags: review?(makemyday) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5bb80260d09b
Follow-up: For gData, cater for both old an new locale API. r=MakeMyDay
You need to log in before you can comment on or make changes to this bug.