Closed Bug 1493521 Opened 4 years ago Closed 4 years ago

Wayland and HiDPI -> Bad scaled menu's

Categories

(Core :: Widget: Gtk, defect)

62 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1466616

People

(Reporter: jean-louis, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180923073627

Steps to reproduce:

I did rebuild Firefox 62 on Ubuntu with Wayland support (https://launchpad.net/~dupondje/+archive/ubuntu/ppa).
Now there is an issue with scaling menu's (properties menu, cut/copy/paste menu) on HiDPi screen!

I have my HiDPi screen on 150% (fractional) scaling.


Actual results:

I would expect all menu's to be scaled correctly 150%, but its not the case.
As you see on the attached screenshot, its shown way to big and on the wrong position!


Expected results:

Correct scaling :)
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
I tested this on the latest nightly, and then its scaled correctly.
But the positioning of the menu is still wrong.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1466616
You need to log in before you can comment on or make changes to this bug.