Closed Bug 1493646 Opened 11 months ago Closed 11 months ago

Browser toolbox shortcut closes the regular toolbox

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: nchevobbe, Assigned: Honza)

References

Details

Attachments

(1 file)

**Steps to reproduce**
1. Open the console
2. Hit the browser toolbox shortcut (Shift + Alt + Cmd + I on OSX)

**Expected results**

The browser toolbox opens

**Actual results**

The browser toolbox does not open and the regular toolbox is closed

---
Priority: -- → P3
Summary: Browser console shortcut closes the regular toolbox → Browser toolbox shortcut closes the regular toolbox
Assignee: nobody → odvarko
My best guess without having looked into this is that `CmdOrCtrl+Alt+I` is being matched by the cmd+shift+opt+i shortcut to open BT which is causing `onClose` to fire https://searchfox.org/mozilla-central/rev/0640ea80fbc8d48f8b197cd363e2535c95a15eb3/devtools/client/framework/toolbox.js#930. It looks like there's some special casing for when the shiftKey doesn't match on OSX: https://searchfox.org/mozilla-central/rev/0640ea80fbc8d48f8b197cd363e2535c95a15eb3/devtools/client/shared/key-shortcuts.js#225-234.
Blocks: 1491749
Thanks Brian for the pointer, that make sense.

The issue is that the keydown event object says `event.key == "ˆ"` while the code would rather expect `event.key == "I"` - where the code is the condition that checks whether the key is alphanumeric. Apparently not.

I added a new condition that also checks the `event.keyCode`.
It's not nice, but I am not seeing better solution.

Honza
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ae757626c524
Browser toolbox shortcut closes the regular toolbox; r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/ae757626c524
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.