Printing of an incorrect number of identical copies of a page

VERIFIED FIXED

Status

()

Core
Printing: Output
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Roland Friedrich, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When printing a page ("All Pages" or any given page) and "Number of copies" is
set to more than 1, an incorrect high number of copies is printed. Example: when
"Number of copies" is set to 3, six or more copies are printed.

This is fully reproducible under OS/2 (Warp 4 and eCS) on different computers
and occurs with Mozilla 1.0RC3 and Build 2002053016 (the only ones I have tested
for a while). (The problem does not occur under Win2000 with Mozilla 1.0RC3.)

The number of printed pages is correct when the number of copies is set to 1.

Comment 1

16 years ago
--> mkaply
Assignee: rods → mkaply
(Assignee)

Comment 2

16 years ago
Do you have number of copies set in your driver as well?
(Assignee)

Comment 3

16 years ago
What printer driver are you using?

What web page were you printing?

Did the web page have more than one page?
(Assignee)

Comment 4

16 years ago
We can't reproduce this. I'm marking WFM due to lack of response from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
verified - works for me
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
When printing on OS/2, the printer will printer the number of copies 
squared. It's taking the copies value in the print dialog times the 
copies value in the job properties.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

16 years ago
Created attachment 89447 [details] [diff] [review]
nsDeviceContextSpecOS2.cpp - set copies in one place

No longer setting copies in the queue processor parameter. I originally set the
number of copies to the printer with this code. I then wrote functions to set
and query the job properties and set the number of copies there. I did not
think these 2 values would get multiplied.

In the future, could you please reply with your comments in the bug so that
others may see them. I could have worked on this problem sooner. Thanks.
(Assignee)

Comment 8

16 years ago
Comment on attachment 89447 [details] [diff] [review]
nsDeviceContextSpecOS2.cpp - set copies in one place

r=mkaply
sr=blizzard (platform specific code)
Attachment #89447 - Flags: superreview+
Attachment #89447 - Flags: review+
(Assignee)

Comment 9

16 years ago
Fixed on trunk.

Sorry for the confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1+
(Assignee)

Comment 11

16 years ago
fixed on branch
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 12

16 years ago
verified fix
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.