Closed Bug 1493728 Opened 11 months ago Closed 10 months ago

dom.serviceWorkers.interception.enabled pref is still defined on Android

Categories

(Core :: DOM: Service Workers, enhancement, P3)

Unspecified
Android
enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: robwu, Assigned: dpino)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file)

The  pref is still defined on Android pref was removed in bug 1251875, but it is still defined in Android's preferences:
https://searchfox.org/mozilla-central/rev/0640ea80fbc8d48f8b197cd363e2535c95a15eb3/mobile/android/app/mobile.js#839
Keywords: good-first-bug
Priority: -- → P3
Here's a patch. I don't know if this would be enough to fix the issue or it's necessary to do something else.
Attachment #9015798 - Flags: review?(rob)
Comment on attachment 9015798 [details] [diff] [review]
Bug-1493728-Remove-stale-Android-preference-dom.serv.patch

Thanks for the patch; It looks good to me.

I'm not a DOM module peer, so I'll redirect review to Ehsan.
Attachment #9015798 - Flags: review?(rob) → review?(ehsan)
Comment on attachment 9015798 [details] [diff] [review]
Bug-1493728-Remove-stale-Android-preference-dom.serv.patch

Review of attachment 9015798 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #9015798 - Flags: review?(ehsan) → review+
Treeherder: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b73919092eea378c01819360240fabc8fea1a56b

I cannot commit. I'd need to get this bug assigned in order to edit it and add "checkin-needed", or I'd need someone to commit for me.
Assigned, feel free to add checkin-needed.

How did you manage to submit a try job (to Treeherder)?
I thought that it required commit access. If you do have commit access, then it seems that you should also have bug editing access.
Assignee: nobody → dpino
Status: NEW → ASSIGNED
:robwu Thanks! About the try job, someone asked me (I don't remember who) to file a ticket requesting "try commit" access (level 1) https://bugzilla.mozilla.org/show_bug.cgi?id=1493072 

What I've noticed is that I cannot add a new keyword to a bug unless I'm assigned. Although now I'm not sure, perhaps I carried this inertia since the times I didn't have any sort of commit access. I can confirm next time.
Keywords: checkin-needed
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/97771a04ec8c
Remove stale Android preference 'dom.serviceWorkers.interception.enabled' r=Ehsan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/97771a04ec8c
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.