Closed Bug 14938 Opened 21 years ago Closed 21 years ago

Mozilla asserts if compiled --disable-client-wallet

Categories

(Toolkit :: Form Manager, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 14932

People

(Reporter: cls, Assigned: morse)

Details

First, you need to apply this patch to get it to compile:
RCS file: /cvsroot/mozilla/xpfe/browser/src/nsBrowserInstance.cpp,v
retrieving revision 1.19
diff -u -r1.19 nsBrowserInstance.cpp
--- nsBrowserInstance.cpp       1999/09/23 17:46:03     1.19
+++ nsBrowserInstance.cpp       1999/09/26 06:25:31
@@ -78,9 +78,9 @@
 #include "nsIDocumentLoader.h"
 #include "nsIObserverService.h"
 #include "nsFileLocations.h"
+#include "nsIFileLocator.h"

 #ifdef ClientWallet
-#include "nsIFileLocator.h"
 #include "nsIFileSpec.h"
 #include "nsIWalletService.h"
 static NS_DEFINE_IID(kIWalletServiceIID, NS_IWALLETSERVICE_IID);

Here's the script output:
cls@amadeus:bin> ./mozilla-apprunner.sh
MOZILLA_FIVE_HOME=/opt/cls/obj/dist/bin
  LD_LIBRARY_PATH=/opt/cls/obj/dist/bin
      MOZ_PROGRAM=./apprunner
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nsNativeComponentLoader: autoregistering /opt/cls/obj/dist/bin/components
nsNativeComponentLoader: autoregistering succeeded
nsUnixToolkitService: Using 'gtk' for the Toolkit.
NS_SetupRegistry() MOZ_TOOLKIT=gtk, WIDGET_DLL=libwidget_gtk.so,
GFX_DLL=libgfx_gtk.so
started appcores
GFX: dpi=100 t2p=0.0694444 p2t=14.4 depth=16
Using '/opt/cls/obj/dist/bin' as the resource: base
initialized appshell
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileName : cls
ProfileDir  : /home/cls/.mozilla/cls
Profile Manager : Profile Wizard and Manager activites : End
PreCondition: "dup release" (0 != mRefCnt) at file
/opt/cls/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 155
Break: at file /opt/cls/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line
155
cls@amadeus:bin>
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Isn't this the same as 14932 -- word for word?

*** This bug has been marked as a duplicate of 14932 ***
Status: RESOLVED → VERIFIED
I agree with morse.  Marked VERIFIED DUPLICATE.
Product: Core → Toolkit
QA Contact: paulmac → form.manager
You need to log in before you can comment on or make changes to this bug.