Closed Bug 14939 Opened 21 years ago Closed 21 years ago

links inside a bulleted item take over the document

Categories

(Core :: DOM: HTML Parser, defect, P3)

x86
Neutrino
defect

Tracking

()

VERIFIED DUPLICATE of bug 7724

People

(Reporter: yossioren, Assigned: rickg)

References

()

Details

Attachments

(1 file)

(WIN2K build 2031)
This document has a < li> bulleted item ("Get more  forums") without a < ul><
/ul> surrounding it.
Everything from the end of that link to the end of the document becomes that
link.

Easy to reproduce:
< li>< a href="wrong place"> don 't click here< /a>< /p>
< a href="right place"> can't click here< /a>< /p>
Attached file test case
Assignee: troy → rickg
Component: Layout → Parser
What's happening is that all the content is getting nested inside of the first A
tag:

html refcount=3<
  head refcount=2<
  >
  body refcount=3<
    a href=http://www.wrong-link.com refcount=6<
      Text refcount=3<\n>
      li refcount=4<
        Text refcount=3< This link takes over the page!\n>
        p refcount=3<
          Text refcount=3<\n\n>
          a href=http://www.proper-link.com refcount=3<
            Text refcount=3<   This link doesn't work!    >
          >
          Text refcount=3<\n>
        >
      >
    >
  >
>
Here's a more severe manifestation of the bug (seen a lot on www.suck.com):

out of the link <a href="here's the link"> inside <p>
the link</a> can't get out of the link
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
LI inhibits A closure.

*** This bug has been marked as a duplicate of 7724 ***
Status: RESOLVED → VERIFIED
Marking as verified duplicate of 7724.
You need to log in before you can comment on or make changes to this bug.